We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 29796
    • 91 Posts
    I installed a freash copy of Revolution 2.2.1 and downloaded articles and codeMirror. First i installed articles, then codeMirror (wich wont install because od compress_js option) .. i checked the error log http://pastebin.com/ZCepaMme and it was full of errors ...

    i deleted all and reinstalled modx ... first thing i turned off that comress_js and tryed to install articles and code mirror again. Code mirror installed successfully .. articles installation console returned me this error:

    /*
    * MODX Console Output
    *
    * @date 2012-04-10 22:24:06
    */
    Attempting to install package with signature: articles-1.6.0-pl
    Package found...now preparing to install.
    Grabbing package workspace...
    Workspace environment initiated, now installing package...

    Error adding field quipComment->name: Array ( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'name')
    Error adding field quipComment->email: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'email')
    Error adding field quipComment->website: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'website')
    Error adding field quipComment->resource: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'resource')
    Error adding field quipComment->idprefix: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'idprefix')
    Error adding field quipComment->existing_params: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'existing_params')
    Error adding index resource to quipComment: Array( [0] => 42000 [1] => 1061 [2] => Duplicate key name 'resource')
    Error adding field quipComment->ip: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'ip')
    Error adding field quipComment->rank: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'rank')
    Error adding field quipComment->approvedby: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'approvedby')
    Error adding field quipComment->deleted: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'deleted')
    Error adding field quipComment->deletedon: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'deletedon')
    Error adding field quipComment->deletedby: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'deletedby')
    Error adding index approvedby to quipComment: Array( [0] => 42000 [1] => 1061 [2] => Duplicate key name 'approvedby')
    Error adding index deleted to quipComment: Array( [0] => 42000 [1] => 1061 [2] => Duplicate key name 'deleted')
    Error adding index deletedby to quipComment: Array( [0] => 42000 [1] => 1061 [2] => Duplicate key name 'deletedby')
    Error adding field quipThread->quip_call_params: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'quip_call_params')
    Error adding field quipThread->quipreply_call_params: Array( [0] => 42S21 [1] => 1060 [2] => Duplicate column name 'quipreply_call_params')


    Could not load class: quipNotifyComment from mysql.quipnotifycomment.
    Could not load class: quipNotifyComment from mysql.quipnotifycomment.
    Error removing field Article->articles_container: Array( [0] => 42000 [1] => 1091 [2] => Can't DROP 'articles_container'; check that column/key exists)
    Error removing field Article->articles_container_settings: Array( [0] => 42000 [1] => 1091 [2] => Can't DROP 'articles_container_settings'; check that column/key exists)
    Successfully installed package articles-1.6.0-pl
    /* EOF */


    Anyone know what is wrong? .. what is the reason of this error log [ed. note: theuros last edited this post 14 years, 5 months ago.]
      • 38121
      • 36 Posts
      Same here + bumping

      Ah well, the bug tracker is a better place for that and it's been filed already:
      http://tracker.modx.com/issues/7604 [ed. note: yogooo last edited this post 14 years, 5 months ago.]
        • 38121
        • 36 Posts
        The answer from Mark Hamstra on the bug tracker:

        Those errors just mean your database is already updated for the latest Quip, and not something to worry about.

        The underlying cause for this will likely be fixed in Revo 2.3 when the package manager is reworked.

        The post can be marked as resolved