We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!

Answered Manager lockout

    • 39287
    • 13 Posts
    Hi everybody,

    I know that manager lockout is kind of a common situation, but I were unable to find any discussion that would help in my situation.

    I can't login to REVO's manager with my admin (a default superadmin). The password is OK (and reset password link works) and I get no error messages, after I press login, it seems to just refresh the page (comes back to login/pwd promt again). And every my login attempt increments the logincount field in user_attributes table.

    No other users have access to mgr, so I'm completely stuck. I tried to clear the cache but it does not help.

    Probably I changed some access rights by mistake, but how to find and correct them now?


    Thanks!

    This question has been answered by afterdark. See the first response.

      • 3749
      • 24,544 Posts
      The first thing to try is deleting all files in the core/cache directory and clearing your browser cache and cookies.


      ------------------------------------------------------------------------------------------
      PLEASE, PLEASE specify the version of MODX you are using.
      MODX info for everyone: http://bobsguides.com/modx.html
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 39287
        • 13 Posts
        Hi Bob, thanks for your answer.

        Of course I did that already. And I tried to login from different browsers (chrome and safari) from two different machines.

        Yesterday after writing my post here I came across this thread: https://forums.modx.com/thread/?thread=30690. But no useful info there except "try a clean install" thing. And I don't want to make a clean install: there's a whole lot of settings I had made to that site (like login, newspublisher, quip, vanilla integration)

        Is there any way to reset Administrator access rights in the DB?

        modx version is 2.2.0-pl2

        I'll try to upgrade to 2.2.1-pl later today.
        UPDATE: upgrade did not help, the problem persists [ed. note: afterdark last edited this post 14 years, 5 months ago.]
        • discuss.answer
          • 39287
          • 13 Posts
          Oh, finally I found the cause.
          In the table `mod_member_groups` the `rank` value of admin (member=1) record was 0. I set it to 1 and it worked.
            • 3749
            • 24,544 Posts
            See if this helps:

            MODX :: Update to 2.2.1-pl, now I cannot log in [Solved]
            https://forums.modx.com/thread/75635/update-to-2-2-1-pl-now-i-cannot-log-in-solved#dis-post-419414

            Were you creating ACLU entries before this happened?
            If so, what kind?
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 39287
              • 13 Posts
              Thanks, but I actually got it solved already.

              But after I upgraded to 2.2.1-pl I have lot's of php warnings every where, and my Vanilla integration stopped working (I suppose, because of that debug info interfering with the request).

              An example:

              Warning: mb_strpos() [function.mb-strpos]: Offset not contained in string in /home/admin-i2/partners.iiko.ru/docs/core/model/modx/filters/modoutputfilter.class.php on line 321



              No real problems in the logfile, except for some db columns missing (I ran setup twice).

              This is my setup log:

              [2012-04-09 19:27:33] (ERROR in xPDOManager_mysql::addField @ /home/admin-i2/partners.iiko.ru/docs/core/xpdo/om/mysql/xpdomanager.class.php : 301) Error adding field modResource->properties: Array
              (
                  [0] => 42S21
                  [1] => 1060
                  [2] => Duplicate column name 'properties'
              )
              
              [2012-04-09 19:27:33] (ERROR in xPDOManager_mysql::addField @ /home/admin-i2/partners.iiko.ru/docs/core/xpdo/om/mysql/xpdomanager.class.php : 301) Error adding field modUser->session_stale: Array
              (
                  [0] => 42S21
                  [1] => 1060
                  [2] => Duplicate column name 'session_stale'
              )
              
              [2012-04-09 19:27:33] (ERROR in xPDOManager_mysql::addIndex @ /home/admin-i2/partners.iiko.ru/docs/core/xpdo/om/mysql/xpdomanager.class.php : 329) Error adding index access to modSession: Array
              (
                  [0] => 42000
                  [1] => 1061
                  [2] => Duplicate key name 'access'
              )
              
              [2012-04-09 19:27:33] (ERROR in xPDOManager_mysql::addField @ /home/admin-i2/partners.iiko.ru/docs/core/xpdo/om/mysql/xpdomanager.class.php : 301) Error adding field modUser->sudo: Array
              (
                  [0] => 42S21
                  [1] => 1060
                  [2] => Duplicate column name 'sudo'
              )
              
              [2012-04-09 19:27:33] (ERROR in xPDOManager_mysql::removeIndex @ /home/admin-i2/partners.iiko.ru/docs/core/xpdo/om/mysql/xpdomanager.class.php : 412) Error removing index parent from modAction: Array
              (
                  [0] => 42000
                  [1] => 1091
                  [2] => Can't DROP 'parent'; check that column/key exists
              )
              
              [2012-04-09 19:27:33] (ERROR in xPDOManager_mysql::removeField @ /home/admin-i2/partners.iiko.ru/docs/core/xpdo/om/mysql/xpdomanager.class.php : 394) Error removing field modAction->parent: Array
              (
                  [0] => 42000
                  [1] => 1091
                  [2] => Can't DROP 'parent'; check that column/key exists
              )
              
              [2012-04-09 19:27:33] (ERROR in xPDOManager_mysql::addField @ /home/admin-i2/partners.iiko.ru/docs/core/xpdo/om/mysql/xpdomanager.class.php : 301) Error adding field modNamespace->assets_path: Array
              (
                  [0] => 42S21
                  [1] => 1060
                  [2] => Duplicate column name 'assets_path'
              )
              
              [2012-04-09 19:27:35] (ERROR @ /setup/index.php) xPDOObject - Called set() with an invalid field name: 0
              [2012-04-09 19:27:35] (ERROR @ /setup/index.php) xPDOObject - Called set() with an invalid field name: 1
              [2012-04-09 19:27:35] (ERROR @ /setup/index.php) xPDOObject - Called set() with an invalid field name: 0
              [2012-04-09 19:27:35] (ERROR @ /setup/index.php) xPDOObject - Called set() with an invalid field name: 1
              [2012-04-09 19:27:35] (ERROR @ /setup/index.php) xPDOVehicle resolver failed: type php (/home/admin-i2/partners.iiko.ru/docs/core/packages/core/modDashboardWidget/4eae977323df752bb2f89a2e30785daa.resolve.dashboardwidgets.resolver)
              [2012-04-09 19:27:35] (ERROR @ /setup/index.php) Could not resolve vehicle for object of class modDashboardWidget; criteria: Array
              (
                  [name] => w_configcheck
              )
              
              




              What can it be?