We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 39326
    • 3 Posts
    I just updated to 2.2.1-pl through my webhost using Softaculous and now I cannot log in to the manager.

    I keep getting the error:
    That account could not be located. Check the username and re-type the password to try again.

    This is even after I had the system send me a reset password email. Using that link and the username and password provided in the email I still cannot log in.

    This question has been answered by markh. See the first response.

      • 18373 ☆ A M B ☆
      • 3,141 Posts
      Hmm first gut instinct says it's unable to get into the database, though that wouldn't allow resetting the password either.

      Open up the error log in core/cache/logs/error.log and see what's in there.
        Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

        Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
        • 39326
        • 3 Posts
        Here are the last few entries from my error.log file.

        [2012-04-05 09:12:38] (ERROR @ /manager/index.php) Attempt to save lazy object: Array
        (
            [id] => 1
            [username] => admin
            [password] => w5J6melr8uMRf1rE56PzMChtOQgs1PKlRDeexNtnZHw=
            [cachepwd] => 8aP6b2NJBmykorKclXUhk3YLO74hOBIlkr8PdgUoXbk=
            [class_key] => modUser
            [active] => 1
            [remote_key] => 
            [remote_data] => 
            [hash_class] => hashing.modPBKDF2
            [salt] => cbdb14ea54314761ec564ed08b7096d6
            [primary_group] => 2
            [session_stale] => 
            [sudo] => 0
            [email] => [email protected]
            [fullname] => Default Admin User
        )
        
        [2012-04-05 09:12:54] (ERROR @ /manager/index.php) Error 42S22 executing statement: 
        Array
        (
            [0] => 42S22
            [1] => 1054
            [2] => Unknown column 'modUser.session_stale' in 'field list'
        )
        
        [2012-04-05 09:12:54] (ERROR @ /manager/index.php) Error 42S22 executing query: SELECT `modUser`.`id` AS `modUser_id`, `modUser`.`username` AS `modUser_username`, `modUser`.`password` AS `modUser_password`, `modUser`.`cachepwd` AS `modUser_cachepwd`, `modUser`.`class_key` AS `modUser_class_key`, `modUser`.`active` AS `modUser_active`, `modUser`.`remote_key` AS `modUser_remote_key`, `modUser`.`remote_data` AS `modUser_remote_data`, `modUser`.`hash_class` AS `modUser_hash_class`, `modUser`.`salt` AS `modUser_salt`, `modUser`.`primary_group` AS `modUser_primary_group`, `modUser`.`session_stale` AS `modUser_session_stale`, `modUser`.`sudo` AS `modUser_sudo`, `Profile`.`id` AS `Profile_id`, `Profile`.`internalKey` AS `Profile_internalKey`, `Profile`.`fullname` AS `Profile_fullname`, `Profile`.`email` AS `Profile_email`, `Profile`.`phone` AS `Profile_phone`, `Profile`.`mobilephone` AS `Profile_mobilephone`, `Profile`.`blocked` AS `Profile_blocked`, `Profile`.`blockeduntil` AS `Profile_blockeduntil`, `Profile`.`blockedafter` AS `Profile_blockedafter`, `Profile`.`logincount` AS `Profile_logincount`, `Profile`.`lastlogin` AS `Profile_lastlogin`, `Profile`.`thislogin` AS `Profile_thislogin`, `Profile`.`failedlogincount` AS `Profile_failedlogincount`, `Profile`.`sessionid` AS `Profile_sessionid`, `Profile`.`dob` AS `Profile_dob`, `Profile`.`gender` AS `Profile_gender`, `Profile`.`address` AS `Profile_address`, `Profile`.`country` AS `Profile_country`, `Profile`.`city` AS `Profile_city`, `Profile`.`state` AS `Profile_state`, `Profile`.`zip` AS `Profile_zip`, `Profile`.`fax` AS `Profile_fax`, `Profile`.`photo` AS `Profile_photo`, `Profile`.`comment` AS `Profile_comment`, `Profile`.`website` AS `Profile_website`, `Profile`.`extended` AS `Profile_extended`, `UserSettings`.`user` AS `UserSettings_user`, `UserSettings`.`key` AS `UserSettings_key`, `UserSettings`.`value` AS `UserSettings_value`, `UserSettings`.`xtype` AS `UserSettings_xtype`, `UserSettings`.`namespace` AS `UserSettings_namespace`, `UserSettings`.`area` AS `UserSettings_area`, `UserSettings`.`editedon` AS `UserSettings_editedon` FROM `modx_users` AS `modUser` LEFT JOIN `modx_user_attributes` `Profile` ON `modUser`.`id` = `Profile`.`internalKey` LEFT JOIN `modx_user_settings` `UserSettings` ON `modUser`.`id` = `UserSettings`.`user` WHERE `modUser`.`username` = ? ORDER BY `modUser`.`id` ASC  - Array
        (
            [0] => 42S22
            [1] => 1054
            [2] => Unknown column 'modUser.session_stale' in 'field list'
        )
        
        [2012-04-05 09:18:26] (ERROR @ /manager/index.php) Error 42S22 executing statement: 
        Array
        (
            [0] => 42S22
            [1] => 1054
            [2] => Unknown column 'modUser.session_stale' in 'field list'
        )
        
        [2012-04-05 09:18:26] (ERROR @ /manager/index.php) Error 42S22 executing query: SELECT `modUser`.`id` AS `modUser_id`, `modUser`.`username` AS `modUser_username`, `modUser`.`password` AS `modUser_password`, `modUser`.`cachepwd` AS `modUser_cachepwd`, `modUser`.`class_key` AS `modUser_class_key`, `modUser`.`active` AS `modUser_active`, `modUser`.`remote_key` AS `modUser_remote_key`, `modUser`.`remote_data` AS `modUser_remote_data`, `modUser`.`hash_class` AS `modUser_hash_class`, `modUser`.`salt` AS `modUser_salt`, `modUser`.`primary_group` AS `modUser_primary_group`, `modUser`.`session_stale` AS `modUser_session_stale`, `modUser`.`sudo` AS `modUser_sudo`, `Profile`.`id` AS `Profile_id`, `Profile`.`internalKey` AS `Profile_internalKey`, `Profile`.`fullname` AS `Profile_fullname`, `Profile`.`email` AS `Profile_email`, `Profile`.`phone` AS `Profile_phone`, `Profile`.`mobilephone` AS `Profile_mobilephone`, `Profile`.`blocked` AS `Profile_blocked`, `Profile`.`blockeduntil` AS `Profile_blockeduntil`, `Profile`.`blockedafter` AS `Profile_blockedafter`, `Profile`.`logincount` AS `Profile_logincount`, `Profile`.`lastlogin` AS `Profile_lastlogin`, `Profile`.`thislogin` AS `Profile_thislogin`, `Profile`.`failedlogincount` AS `Profile_failedlogincount`, `Profile`.`sessionid` AS `Profile_sessionid`, `Profile`.`dob` AS `Profile_dob`, `Profile`.`gender` AS `Profile_gender`, `Profile`.`address` AS `Profile_address`, `Profile`.`country` AS `Profile_country`, `Profile`.`city` AS `Profile_city`, `Profile`.`state` AS `Profile_state`, `Profile`.`zip` AS `Profile_zip`, `Profile`.`fax` AS `Profile_fax`, `Profile`.`photo` AS `Profile_photo`, `Profile`.`comment` AS `Profile_comment`, `Profile`.`website` AS `Profile_website`, `Profile`.`extended` AS `Profile_extended`, `UserSettings`.`user` AS `UserSettings_user`, `UserSettings`.`key` AS `UserSettings_key`, `UserSettings`.`value` AS `UserSettings_value`, `UserSettings`.`xtype` AS `UserSettings_xtype`, `UserSettings`.`namespace` AS `UserSettings_namespace`, `UserSettings`.`area` AS `UserSettings_area`, `UserSettings`.`editedon` AS `UserSettings_editedon` FROM `modx_users` AS `modUser` LEFT JOIN `modx_user_attributes` `Profile` ON `modUser`.`id` = `Profile`.`internalKey` LEFT JOIN `modx_user_settings` `UserSettings` ON `modUser`.`id` = `UserSettings`.`user` WHERE `modUser`.`username` = ? ORDER BY `modUser`.`id` ASC  - Array
        (
            [0] => 42S22
            [1] => 1054
            [2] => Unknown column 'modUser.session_stale' in 'field list'
        )
        
        [2012-04-06 02:03:38] (ERROR @ /index.php) Error 42S22 executing statement: 
        Array
        (
            [0] => 42S22
            [1] => 1054
            [2] => Unknown column 'modResource.properties' in 'field list'
        )
        
        


        After checking the database, those fields definitely don't exist. Where in the setup/installation, can I find the update scripts necessary to update the database? I'm not sure why they didn't run, but from the log file, it's obvious they didn't. [ed. note: joshminnie last edited this post 14 years, 5 months ago.]
        • discuss.answer
          • 18373 ☆ A M B ☆
          • 3,141 Posts
          Hmm I'm not sure how Softaculous performs upgrades, but I'd suggest uploading the 2.2.1 setup directory entirely (I'll assume softaculous did upgrade all files..) and running it manually at site.com/setup/. It should update all fields at that point.
            Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

            Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
            • 39326
            • 3 Posts
            That fixed it. Thank you.
              • 18373 ☆ A M B ☆
              • 3,141 Posts
              Glad you got it fixed! smiley
                Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.