We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37984
    • 215 Posts
    The homepage will display (with errors), as will the manager login screen. However, once the login process is completed, this error displays:

    Fatal error: Call to a member function setNamespace() on a non-object in /www/core/model/modx/moddashboardwidget.class.php on line 104


    Also, internal pages do not display on the live site - instead, I get these errors:

    Warning: include_once(/www/core/components/getresources/include.parsetpl.php) [function.include-once]: failed to open stream: No such file or directory in /www/core/cache/includes/elements/modsnippet/1.include.cache.php on line 412

    Warning: include_once() [function.include]: Failed opening '/www/core/components/getresources/include.parsetpl.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /www/core/cache/includes/elements/modsnippet/1.include.cache.php on line 412

    Fatal error: Call to undefined function parsetpl() in /www/core/cache/includes/elements/modsnippet/1.include.cache.php on line 473



    My confusion is that when I completed the upgrade, MODX said that it had been completed successfully without any issues. Now my whole site is broken. What gives?

      Jesse Couch
      MODX Aficionado, Front-End Designer & Developer
      http://www.designcouch.com
      • 22303 MODX Staff
      • 10,725 Posts
      Sounds like you may have overwritten your core/components/ directory. Also, if you had any custom dashboards installed, I would disable or remove those before doing the upgrade...
        • 37984
        • 215 Posts
        I'm using Coda to upload 2.2.1 to my server, and I used the merge option vs. replace. In my understanding, this should not overwrite core/components, correct?
          Jesse Couch
          MODX Aficionado, Front-End Designer & Developer
          http://www.designcouch.com
          • 37984
          • 215 Posts
          Update: the core/components directory was overwritten, as was the core/config/config.inc.php. Luckily, I have site backup done on my server once a week and not much data was lost. A big HOWEVER though is that I am having major issues restoring from said backup, as the install of 2.2.1 seems to have changed something on my database. I am now getting the following error when trying to log into the manager:

          Fatal error: Call to a member function get() on a non-object in /www/core/model/modx/modmanagerresponse.class.php on line 41


          The site itself is not showing correctly either, as it seems that some of the components will need to be reinstalled, so the major issue is being able to re-access the manager. Please someone help - this site was complete and ready for launch and I need to get it fixed for launch the middle of next week!
            Jesse Couch
            MODX Aficionado, Front-End Designer & Developer
            http://www.designcouch.com
            • 22303 MODX Staff
            • 10,725 Posts
            If you are restoring from backup, you'll need the database from the backup as well. 2.2.1 did indeed upgrade the database and made several not insignificant changes to them.
              • 37984
              • 215 Posts
              I actually have the database from backup but it's still throwing that error. Is it possible to go in and manually change back the database modifications, or are they too extensive?
                Jesse Couch
                MODX Aficionado, Front-End Designer & Developer
                http://www.designcouch.com
                • 22303 MODX Staff
                • 10,725 Posts
                I don't understand, if you have the database backup from before the upgrade, and the backup of the filesystem from the same point in time, there should not be an error. huh
                  • 37984
                  • 215 Posts
                  That's my point of confusion as well. I attempted to install 2.2.1 yesterday (April 3) and the site backup is listed as having been performed on April 1 in my CPanel. I'm in the process of having my host send me a new DB backup file. Sorry to confuse you.
                    Jesse Couch
                    MODX Aficionado, Front-End Designer & Developer
                    http://www.designcouch.com
                    • 37984
                    • 215 Posts
                    Had to do a full site restore from the provider backup, but the problem has now been resolved. Thanks for your responses, Jason. You're always a great help on these forums.
                      Jesse Couch
                      MODX Aficionado, Front-End Designer & Developer
                      http://www.designcouch.com
                      • 38846
                      • 30 Posts
                      I am having similar issues. However I am doing this on a MAMP server. I have manually copied the files from the 2.2.1 install folder to the MAMP server making sure not to overwrite the config files and the components folder but I am still getting modmanangerrespnse errors.

                      Were you able to resolve this issue and complete an install of 2.2.1? If so what did you do?