On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • I know that this is an issue which has been looked at yet I've been unable to find a resolution and wanted to ask for help.

    I've basically set the following Multi Item Grid to be used within my site with the following info in Form Tabs:-

    [
    {"caption":"Options", "fields": [
    {"field":"title","caption":"Title","inputTV":"productoption_title"},
    {"field":"code","caption":"Code","inputTV":"productoption_code"},
    {"field":"price","caption":"Price","inputTV":"productoption_price"}
    ]}
    ]

    and the following in Grid Columns:-

    [
    {"header": "Title", "width": "160", "sortable": "true", "dataIndex": "title"},
    {"header": "Code", "width": "160", "sortable": "true", "dataIndex": "code"},
    {"header": "Price", "width": "160", "sortable": "true", "dataIndex": "price"}
    ]

    I'm pretty sure that I've set everything up correctly albeit this is my first dabblings when using MIGX and have ensured that all the TV's have been created too and that I haven't assigned any of the TV's other than productoptions_migx to a template.

    The issue I have is that I when I come to access the grid I basically get a new window to open which sits constantly loading and does nothing. I've read around on the forums and firstly looked to ensure that the file permissions on /assets/components/migx/connector.php is set to 755 which it was. I then used Firebug as described in a previous to check what was happening which as expected I receive the 404 not found message when trying to connect to /assets/components/migx/connector.php. I've also tried patching the add on by using the following files Bruno17-multiItemsGridTV-3a20731.zip and ensuring that I cleared cache. Unfortunately I'm in the same position with the loading screen yet unclear how to resolve it.

    Just wondered if anyone can help as to what could be going wrong?
    • In order to add to my post I should say that when I type <domain>/assets/components/migx/connector.php directly into the browser it displays my actual site as oppose to a 404 error. Is this the issue as to why the connector.php cannot be found.
      • perhaps I can see what goes wrong, when I could get access to this installation.
          -------------------------------

          you can buy me a beer, if you like MIGX

          http://webcmsolutions.de/migx.html

          Thanks!
        • We had a similar issue. In our case it as Apache refusing to execute .php files that are group writeable so we made sure that connector.php and indeed everything in components was not group writeable.
          • Many thanks to you both for getting back to me. I have checked on the site that I have the components directory set to chmod755 which unfortunately hasn't resolved the issue for me. I should say that I have tested MIGX on a local install which works perfectly so presumably has something to do with the environment that it is in. Have sent you Bruno17 a private message with details of access if that is ok.
            • Just wanted to thank Bruno17 for all his help earlier on in the week and sorting the issue out. Basically to resolve this problem you need to ensure that you don't just set the file permissions for the migx folder to 755 yet start from assets and get it the recursively chmod everything to be 755.
              • I've been using the mighty MIGX without a hitch for some time now but I've just run into the classic loading spinner issue outlined in this and a few other threads since shifting a site to a live server last week.

                MySQL 5.0.95
                PHP 5.2.14
                ModX Revo 2.1.3 with MigX 1.1 has the issue.
                Tried a test install on the same server of ModX 2.2.0 with nothing but TinyMCE and MigX 2.0.0 beta 2: same problem.

                I've tried changing permissions on connector.php as suggested here, tried upgrading MigX. No luck.

                I've also been doing some testing to figure out why some fields still work and some can't be opened for editing. I thought at first it was only rich text TVs that caused the dreaded spinner but it's not as simple as that. Some HTML formatting seems to be safe, but nested tags, for example
                <p><strong>foo</strong></p>

                cause it to seize up.

                If I add the same HTML formatting to a plain text field it can also cause the same problem, i.e. the endless loading spinner. So it's clearly not a conflict with TinyMCE.

                All very mysterious and very frustrating. I thought these details might help Bruno17 or other hardcore MIGX fans get to the bottom of this bug.

                Thanks
                • anyone ever fix this?
                  • Change assets/components/migx/connector.php file permissions from 0777 to 0755. It worked for me!