The problem is more or less resolved due to Site5 brilliant support team.
1. File permissions. ModX Revo appears to be very strict on them. The only working solution: 0755 for dirs and 0644 for files. It can be VERY important at Site5 because they use suPHP.
2. zlib.output_compression in .htaccess. Like to use this feature but at Site5 it demands special tuning. Had the following lines in .htaccess:
php_flag zlib.output_compression On
php_value zlib.output_compression_level 5
At Site5 no php_flag is allowed in .htaccess, users should make a custom php.ini instead.
To Susan: yes Your guess was a pretty one but in my case it was not the wrong DSN who lead to the the error 500. Thanks nevertheless!
P.S. Would like to underline that Site5 support guys are really smart. Hostgator is less user friendly.