I'm using a monitoring service and ever few days I get a notice that
http://schleckpa.com is no longer responding, sure enough it's down. I clear the cache and it's back.
I've looked in the MODx Error log and I find a mess of stuff about gallery, so I removed it, since we are not using it, also removed from the template, still get the error 500 every now and again.
Any ideas?
-
☆ A M B ☆
- 2,213 Posts
Do you have any opcaching enabled on the server? If so what?
The line from PHP info
Opcode Cache enabled, 4,294,967,296 bytes, 16 split(s), with 16384 slots each
Thanks for jumping in here.
-
☆ A M B ☆
- 2,213 Posts
You might want to try disabling opcaching (apc, eaccelerator, xcache), and see if that resolves the problem. The can increase server performance, but in doing so add another layer that can break.
-
☆ A M B ☆
- 113 Posts
We host quite a few Revo sites on Rackspace Cloud Sites as well and have also noticed the 500 error on occasion. It never seems to last long and doesn't happen consistently.
We did encounter a severe error involving the modx cache a few weeks ago that sent a site's compute cycles through the roof and required rackspace to ratelimit and eventually roll back the site to avoid bringing down the system. The site has moderate traffic, about 6000 visitors per day, and it appears to have been related to the actions of clearing the cache and/or updating the phpthumbof package during a high traffic time. Phpthumbof started creating thumbnails recursively and the modx error log climbed from empty to 500mb in a matter of seconds. We never did determine the cause.
Did you disable Opcode Cache? If so, did it have the desired result?
I have the same exact setting for Opcode Cache. Can someone verify that disabling this keeps the error 500 from occuring on Rackspace Cloud Sites? I set uptime tracking on all of our sites today, and I've already received an error.