We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36632
    • 202 Posts
    PHP Fatal error: Call to undefined method Login::loadController() in /var/www/vhosts/domainname.org/httpdocs/core/cache/includes/elements/modsnippet/4.include.cache.php on line 61

    Can anyone make sense of this error? The site in question is down.

    I delete the cache and the same error keep happening. Here is the cache file from above. It's the login:
    <?php
    function elements_modsnippet_4($scriptProperties= array()) {
    global $modx;
    if (is_array($scriptProperties)) {
    extract($scriptProperties, EXTR_SKIP);
    }
    /**
     * Login
     *
     * Copyright 2010 by Jason Coward <[email protected]> and Shaun McCormick
     * <[email protected]>
     *
     * Login is free software; you can redistribute it and/or modify it
     * under the terms of the GNU General Public License as published by the Free
     * Software Foundation; either version 2 of the License, or (at your option) any
     * later version.
     *
     * Login is distributed in the hope that it will be useful, but WITHOUT ANY
     * WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
     * A PARTICULAR PURPOSE. See the GNU General Public License for more details.
     *
     * You should have received a copy of the GNU General Public License along with
     * Login; if not, write to the Free Software Foundation, Inc., 59 Temple
     * Place, Suite 330, Boston, MA 02111-1307 USA
     *
     * @package login
     */
    /**
     * MODx Login Snippet
     *
     * This snippet handles login POSTs, sending the user back to where they came from or to a specific
     * location if specified in the POST.
     *
     * @package login
     *
     * @property textfield actionKey The REQUEST variable containing the action to take.
     * @property textfield loginKey The actionKey for login.
     * @property textfield logoutKey The actionKey for logout.
     * @property list tplType The type of template to expect for the views:
     *  modChunk - name of chunk to use
     *  file - full path to file to use as tpl
     *  embedded - the tpl is embedded in the page content
     *  inline - the tpl is inline content provided directly
     * @property textfield loginTpl The template for the login view (content based on tplType)
     * @property textfield logoutTpl The template for the logout view (content based on tplType)
     * @property textfield errTpl The template for any errors that occur when processing an view
     * @property list errTplType The type of template to expect for the error messages:
     *  modChunk - name of chunk to use
     *  file - full path to file to use as tpl
     *  inline - the tpl is inline content provided directly
     * @property integer logoutResourceId An explicit resource id to redirect users to on logout
     * @property string loginMsg The string to use for the login action. Defaults to
     * the lexicon string "login".
     * @property string logoutMsg The string to use for the logout action. Defaults
     * to the lexicon string "login.logout"
     */
    require_once $modx->getOption('login.core_path',null,$modx->getOption('core_path').'components/login/').'model/login/login.class.php';
    $login = new Login($modx,$scriptProperties);
    if (!is_object($login) || !($login instanceof Login)) return '';
    
    $controller = $login->loadController('Login');
    $output = $controller->run($scriptProperties);
    return $output;
    }
    


    This is for a Revo site 2.1.3 site. I honestly don't know how or why a cache file can cripple a site. I uploaded a simple index.html file but that doesn't display at all. Nothing in the MODX Error file.; it's blank.

    While the site was down I upgraded it to 2.2 traditional. Manager works flawlessly The site is https. The system setting reflects that. All files are in httpdocs per hosting setup. htaccess has a rewrite rule to display https in the url. The Manager works without any issues at all, even displaying https in the URL.

    I'm going to run setup and see if that helps. Meanwhile, could someone help me troubleshoot this? It's the very worst possible time for this particular site to be down. (breathe, breathe, breathe).
      • 33968
      • 863 Posts
      Did you clear the cache using the manager option or manually delete everything in the core/cache folder? Try the latter if you haven't already...
        • 36632
        • 202 Posts
        Both. I always manually delete the core/cache folder if I run into problems. Reviewing the error logs and it's the same as above. Ultimate parent shows up in the cache but the error logs never reference it. It's always the login cache 4.include.cache.php.

        I wonder if I'm somehow missing a file. Not sure what I can do next. Suggestions please!
          • 33968
          • 863 Posts
          Is the Login snippet up to date? Try uninstalling that, clear the cache and see if the site works, then reinstall and see what happens...
            • 36632
            • 202 Posts
            Brilliant Lucas! I uninstalled Login and the site works. But Login is what the site depends on as people need to login to view "parents only" info about their kids' school.

            I haven't reinstalled it because a getResources page isn't working. It works when I select it from a Wayfinder Nav that doesn't have UltimateParent in it. I'm removing that and letting it build the sidebar nav without it.
              • 36632
              • 202 Posts
              I got the site working again by installing the backup files and db.

              Unfortunately the custom snippets don't load in the front end. And none of the snippets display in the Manager.