We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37393
    • 68 Posts
    Hi,
    got a problem with Newspublisher (latest version), when i click the submit button at bottom below the forms the page goes blank and seems to have failed, but cancel button works fine, i get redirected to its parent.

    The snippet that the frontend page uses:
    [[!NewsPublisher? 
    &parentid=`96` 
    &cancelid=`96` 
    &searchable=`1` 
    &cacheable=`1` 
    &hidemenu=`0` 
    &postid=`[[*id]]`
    ]]


    This is what i get in the error log, it seems like a FURL issue, NP seems to ignore the furl settings in the core:
    [2012-02-15 14:39:40] (ERROR @ /index.php) ``73`</span>` is not a valid integer and may not be passed to makeUrl()


    I have
    <base href="[[!++site_url]]" />
    in my template.

    Friendly url`s:
    Use friendly urls = ON
    Use friendly alias path = ON

    MODX Revolution 2.2.0-pl2 traditional
    PHP 5.3.9
    MYSQL 5.5.20
    Apache 2.2.14
    CentOS 6


    My thoughts are that Newspublisher is failing to do the function makeUrl for some weird reason, i have installed it properly and have been reading the guides on Bob`s website.

    Any ideas, anyone?
      IntoVPS - VPS hosting service with super-fast response.
      If MODx does not suit your needs then you have a lack of imagination.
      • 37393
      • 68 Posts
      I have tried with friendly url`s off, it does not work. I still get the blank page when submitting, i never get redirected thought.
        IntoVPS - VPS hosting service with super-fast response.
        If MODx does not suit your needs then you have a lack of imagination.
        • 3749
        • 24,544 Posts
        Hm . . . I just tried it and it works fine (though I'm using NP 1.3.0).

        Do you have this in all your templates:

        <base href="[[++site_url]]" />



        ---------------------------------------------------------------------------------------------------------------
        PLEASE, PLEASE specify the version of MODX you are using . . . PLEASE!
        MODX info for everyone: http://bobsguides.com/modx.html
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 37393
          • 68 Posts
          where do i find version 1.3.0 huh in package manager it says version 1.2.1 pl2
            IntoVPS - VPS hosting service with super-fast response.
            If MODx does not suit your needs then you have a lack of imagination.
            • 37393
            • 68 Posts
            Ok, i have updated the files that are available and updated on github for NP. I still get a white page, and when i press the cancel button without setting a &cancelid param, it takes me to following url:
            (Create new page, page id 86)
            http://www.domain.com/86

            ..instead of the actual page (http://www.domain.com/news/create-page)

            but when i specify it in the param like &cancelid=`86`, it does take me in the right direction.

            When i click "submit" the page just goes blank without doing any action, no page appears in the tree or in the db.

            I am using friendly urls with alias paths enabled.

            I have this in my modx error log:
            [2012-02-16 13:28:09] (ERROR @ /index.php) ``86`</span>` is not a valid integer and may not be passed to makeUrl()
            [2012-02-16 13:28:25] (ERROR @ /var/www/html/core/components/newspublisher/classes/newspublisher.class.php : 1631) PHP warning: Invalid argument supplied for foreach()
            [ed. note: bowkilled last edited this post 14 years, 7 months ago.]
              IntoVPS - VPS hosting service with super-fast response.
              If MODx does not suit your needs then you have a lack of imagination.
              • 3749
              • 24,544 Posts
              I don't think it's a problem with paths. It looks like a span tag is getting injected into the properties somehow.
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting
                • 37393
                • 68 Posts
                  IntoVPS - VPS hosting service with super-fast response.
                  If MODx does not suit your needs then you have a lack of imagination.
                  • 3749
                  • 24,544 Posts
                  Those posts are 5-years old, so it's unlikely that's the problem unless something is misconfigured in your setup. Do you have the base href tag in all templates?

                  The new version of NewsPublisher should be out in a day or two, so you might wait for that.


                  ---------------------------------------------------------------------------------------------------------------
                  PLEASE, PLEASE specify the version of MODX you are using . . . PLEASE!
                  MODX info for everyone: http://bobsguides.com/modx.html
                    Did I help you? Buy me a beer
                    Get my Book: MODX:The Official Guide
                    MODX info for everyone: http://bobsguides.com/modx.html
                    My MODX Extras
                    Bob's Guides is now hosted at A2 MODX Hosting
                    • 37393
                    • 68 Posts
                    Bob, i have just tried the NP 1.2.1 on a fresh install of modx rev 2.2.0 pl2 and it works fine. But am still curious about the primary install that NP does not work on.
                      IntoVPS - VPS hosting service with super-fast response.
                      If MODx does not suit your needs then you have a lack of imagination.
                      • 3749
                      • 24,544 Posts
                      My First guess would be TinyMCE mucking with your NewsPublsiher tag.

                      Have you viewed the NP tag in straight HTML (or in the DB)?


                      ---------------------------------------------------------------------------------------------------------------
                      PLEASE, PLEASE specify the version of MODX you are using . . . PLEASE!
                      MODX info for everyone: http://bobsguides.com/modx.html
                        Did I help you? Buy me a beer
                        Get my Book: MODX:The Official Guide
                        MODX info for everyone: http://bobsguides.com/modx.html
                        My MODX Extras
                        Bob's Guides is now hosted at A2 MODX Hosting