We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 19309
    • 49 Posts
    Just wanted to let you guys know what I just found out:

    I had problems saving resources. The saving progress bar started over and over again. The resource was correctly saved but the screen didn’t refresh. Since I found out that this only happened using Firefox, I investigated a little.

    The Result: “SmartVideo For YouTube”, a little Firefox add-on which gives you some control over how videos are handled and started, was the problem. After deactivating the add-on, everything was normal again. Strange enough, because there is no video in the MODX backend which the add-on could handle.

    But anyway, I learned: Deactivating all browser extensions might help if something doesn’t work in MODX manager ;-)
      • 33988
      • 110 Posts
      I've had a similar experience with more than 1 2.2 install on more than 1 server. I've tried Firefox and Chrome. Addons disabled, cookies cleared, cache cleared. I still haven't solved it. If anyone finds out anything, let me know.

      Edit: Appears as though quick edit works. [ed. note: thekiller237 last edited this post 14 years, 7 months ago.]
        Sal Sodano
        President & Co-Founder of SkyToaster
        My Website Salscode.
        • 18373 ☆ A M B ☆
        • 3,141 Posts
        - Disable all plugins one by one. VersionX v1 on any MODX install > 2.0.8 gives those exact symptoms, VersionX v2 will be stable from 2.0.8-2.2 upon release, current dev releases are at own risk. Other addons that have not been updated for 2.2 can also break that behavior.

        - If this happened after moving, carefully inspect the error log - there's often a path misconfiguration somewhere, for example in the Gallery or Articles system settings.

        - Again, check out the error log. When everything's set up right there shouldn't be anything get written to it.

        - Open up Firebug / Dev Tools before saving, and check out the response to the resource/update or resource/create connector. Endless save loops are often caused by fatal php errors which, if not in the error log, is present in the response to the connector.
          Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

          Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
          • 1343 ☆ A M B ☆
          • 2,213 Posts
          A few more notes on the issue...

          This is a fresh install of 2.2 pl2 advanced, and there are no errors (modx/system).

          The packages installed: CodeMirror, Copyright, FormIt, getResources, HandyMan, Login, MetaX, and Wayfinder

          If you edit the resources normally only the first save seams to take, you don't see future edits unless you view them in Quick Edit (as if normal editing is cached).

          The CSS/JS Caching along with HTML5 cache is disabled, along with a few other for extra overkill.
            Patrick | Server Wrangler
            About Me: Website | Tweets |  MODX Hosting
            • 33988
            • 110 Posts
            So if we are getting an issue that says "POST www.domain.com/connectors/resource/locks.php FAILED" what would we do to correct that endless save loop?

            PS: Thanks Mark for stepping in on this.
              Sal Sodano
              President & Co-Founder of SkyToaster
              My Website Salscode.
              • 18373 ☆ A M B ☆
              • 3,141 Posts
              So if we are getting an issue that says "POST www.domain.com/connectors/resource/locks.php FAILED" what would we do to correct that endless save loop?

              That's harmless usually.

              The request to the resource update or create processor is what will hold the answer. It will likely come back with a 200 OK response, but in the response body there's a php fatal error...
                Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

                Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
                • 577
                • 132 Posts
                I had saving problems without the JS issues. It fits the topic so I thought I would share. My version of MODx has been going since the early 2.0rc days. Back then alias was not required (or at least had no validation to make it so) . So needless to say I had some older resources that are holding data but not used to resolve pages and thus alias is not really needed. Well in 2.2 when setting TV values and then saving, it appears to never save and drove me crazy. Then I realized that on the main content tab I had a validation error telling me alias is required. But there is no notification of this when you are saving with another tab active.

                Hope this saves someone a few grey hairs.

                Already logged as a "bug" . Though not really a bug there needs to be some notification of error when on any tab.
                  "One of these days I will get around to my own website... Its only been about 12 years... maybe tomorrow smiley"
                  • 6038
                  • 228 Posts
                  I was having the same issue - saving a resource was saving, but the progress bar was never finishing.
                  I'd tried all the usual suspects - compress_js, compress_css off, tried different browsers, mod_security. There were no ajax errors, or php log errors, however I was getting a javascript console error:
                  Uncaught SyntaxError: Unexpected token <

                  Thanks to this thread I found the problem was 'versionX' addon (v1). I had installed this through package manager into Revo 2.2.2, before discovering that this version is not compatible with 2.2, whereupon I uninstalled it.

                  However, despite uninstalling and removing the package, some stuff was left around that was interfering with resource saving (i suspect the versionx plugin). After deleting the namespace entry, actions menu item, database tables, package files, component files and clearing the cache, the problem was gone. [ed. note: christianhanvey last edited this post 14 years, 4 months ago.]