We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 38662
    • 8 Posts
    Fresh install of MODx Rev 2.2

    Running on PHP 5.3

    cURL enabled

    When I try to download it gets stuck on the "Please Wait... Downloading..."

    Tried checking if any outgoing connections are being blocked and can't see anything that relates to MODx.

    The folder permissions of core/packages are set to 755.

    Anyone have any clue what is going on?
      • 38662
      • 8 Posts
      So I've noticed other people have been receiving similar error logs to this one:

      [2012-02-13 14:55:29] (ERROR @ /connectors/workspace/packages-rest.php) MODX could not download the file. You must enable allow_url_fopen, cURL or fsockopen to use remote transport packaging.
      [2012-02-13 14:55:29] (ERROR @ /connectors/workspace/packages-rest.php) Could not download package at: http://modx.s3.amazonaws.com/extras/4d556bc5b2b083396d0007e9/tinymce-4.3.1-pl.transport.zip


      Both allow_url_fopen and cURL are on by fsockopen isn't. Is fsockopen necessary?

      I'd love to take clients onto Rev but I've been reluctant because there always seems to be some package issue... so I'm still mixing it up with Evo and Wordpress depending on needs.
        • 39961
        • 25 Posts
        Any update on this issue - I have the same problem. Transferred a site from my local dev to a live server and things have slipped a little. Both errors above apply to me now :-(
          • 39961
          • 25 Posts
          OK, solved 1 - well, actually my developer did!...

          You need to changes the permissions on the folder core/packages to 777. This will cure the 'downloading' issue!
            • 39961
            • 25 Posts
            Actually - this seems have sorted both issues actually; updates now installing.

            Using Rev2.2.2 BTW.