We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 26805
    • 11 Posts
    Hi folks,

    I've just upgraded my modx installation from 2.1.3-pl to 2.2-pl. Now, after the upgrade, I 've run into two problems:

    1. the manager login screen looks kinda weird. Below the login form, which looks just as usual, there is the well-known title bar of the modx manager displaying the site title and the modx version (which is 2.2-pl) and below that there is an '1'. Nothing more, just the digit '1'.

    2. after logging in the manager turns white. FireBug told me there is a 500 Internal Server Error. I looked into the /var/log/apache2/error.log. Here's what I've found there:


    PHP Fatal error: Call to undefined method modManagerControllerDeprecated::loadErrorHandler() in /var/www/xyz/modx-2.1.3-pl/manager/controllers/default/security/login.php on line 31...

    I'll describe the steps that I followed to upgrade the installation:

    1. I copied the modx-2.1.3-pl to a directory called modx-upgrade
    2. I copied the modx-2.2-pl files into that directory as well, overwriting all of the older files
    3. I re-linked a symbolic link that Apache uses to find the modx folder to that directory
    4. I started the /setup/... process which led me through the upgrade. There were some warnings regarding the database. Unfortunately I ignored them because they appeared to be related to some installed plugins... but I could be wrong. After repeating the steps once more the warnings did not appear again. Everything else appeared to be successful.

    I rechecked every file and directory permission. They all look good. What might have gone wrong here?


    Thanks a lot!

    Cheers,
    Hendrik


    //EDIT: solved by starting over again. I extracted 2.2-pl only and copied config.core.php, manager/config.core.php, core/config/config.inc.php, all components, assets and all custom stuff over to the 2.2-pl directory. After that I walked through setup, upgrade. I ran into another problem regarding compress_js. I had to turn that off to make the manager work again (related to https://forums.modx.com/thread/72857/setup-and-manager-issues?page=2#dis-post-406201).

    Eventually, everything works like a charm again. Umh, nearly everything. For some reason I have not yet managed to figure out component updates don't work. But I'll figure that one out too.

    Thanks nevertheless! [ed. note: SeveQ last edited this post 14 years, 7 months ago.]
      • 39451
      • 1 Posts
      Just wanted to thank you for this post.
      I just ran into the same issue upgrading from 2.1.3 - 2.2.1-pl (Old but bugged login window and the php error you described).

      Well I didn't had to disable the js-compression but I've already seen this issue on another host

      The only way to end the upgrading process was the way you described:

      • Blank directory with just the core and setup folder from the advanced installation
      • Copy over the config.core.php, manager/config.core.php and core/config/config.inc.php
      • Copy over the assets, core/components and in my case the upload and core/extensions folders
      • Now run the setup do an upgrade and it should work perfectly

      --Michael
        • 26805
        • 11 Posts
        Glad I could help. smiley
          • 38677
          • 21 Posts
          We just upgraded one of our client's site from 2.0.8 to 2.2.4. Ran into the same problem. We followed SeveQ's guide and managed to upgrade the framework.

          One additional 'quirk' that we experienced. Our FURL weren't working anymore after the upgrade. We just set the system setting 'Use Friendly URLs' to no, cleared the cache and then set 'Use Friendly URLs' back to Yes. That did the trick.

          Now on to using the Articles extension...
            • 6038
            • 228 Posts
            Thanks to the OP for this post, which steadied my nerve through what should have been a straightforward upgrade when it went skewiff!
              • 43025
              • 4 Posts
              Upgrade from 2.1.1 to 2.2.7 (avanced)

              That is how it worked for me:

              1.- Download modx-2.2.7-pl-advanced.zip anc unzip in empty folder.
              2.- Copy all old folders except core and setup
              3.- Diable .htacces rule for not allowinf acces to setup

              #RewriteRule ^_?setup - [F,L]

              4.- Enable zlib compresion

              In php.ini:

              zlib.output_compression = On
              zlib.output_compression_level 5

              Or in .htaccess

              php_flag zlib.output_compression On
              php_value zlib.output_compression_level 5

              Restart Apache if you do it in php.ini

              If you can not enable it on your host provider then disable in table modx_system_settings

              compress_css 0
              compress_js 0

              6.- Donwload modx-2.2.7-pl and copy over manager folder and connectors folder. (This was the different for me!!!)
              Without this step manager show a popup with an error:

              Unexpected token <:

              The problem is that connectors folder does not have this script:

              WEB_ROOT/connectors/system/derivatives.php

              7.- Copy over the config.core.php, manager/config.core.php and core/config/config.inc.php

              8.- Clear cache.

              5.- Run setup and select upgrade.

              // EDIT:

              I had to disable compress_css and compress_js even with zlib enable. I do not know what exactly do those settings. More info: https://forums.modx.com/forums/thread/28517/compress-css-and-compress-js-break-manager#dis-post-153245

              And I have to change this line:

              if (!defined('MODX_CORE_PATH')) define('MODX_CORE_PATH', dirname(dirname(dirname(__FILE__))) . '/core/');

              In file D:\www\newlayoutmerge.snaprent.net\manager\min\index.php

              because I commented this other:

              //define('MODX_CORE_PATH', '/home/path/core/');

              in file D:\www\newlayoutmerge.snaprent.net\manager\config.core.php [ed. note: josecelano last edited this post 13 years, 4 months ago.]
                • 47812
                • 2 Posts
                Quote from: SeveQ at Feb 10, 2012, 02:36 PM
                1. the manager login screen looks kinda weird. Below the login form, which looks just as usual, there is the well-known title bar of the modx manager displaying the site title and the modx version (which is 2.2-pl) and below that there is an '1'. Nothing more, just the digit '1'.

                2. after logging in the manager turns white. FireBug told me there is a 500 Internal Server Error. I looked into the /var/log/apache2/error.log. Here's what I've found there:


                PHP Fatal error: Call to undefined method modManagerControllerDeprecated::loadErrorHandler() in /var/www/xyz/modx-2.1.3-pl/manager/controllers/default/security/login.php on line 31...

                You just need to clear /core/cache/ folder.