We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 34027
    • 30 Posts

    We're trying to install a package from modx.com, but when we click the "download" button, the package manager fails with the following error:

    
    Forbidden
    
    You don't have permission to access /connectors/workspace/packages-rest.php on this server.
    
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    


    This appears to be a 403 Forbidden error generated by our own webserver trying to serve /connectors/workspace/packages-rest.php from our own site. I've verified this by using Firebug to look at the AJAX request.

    This is on a clean installaation of MODx installed at our ISP. I have the exact same version installed on my laptop, and I don't have any problem.

    Running the connector directly in a browser does not result in an Apache generated HTTP error. Instead it returns a JSON-formatted access denied message but with a 200 HTTP OK error code. This is as expected, because I haven't faked the modauth header.

    I've poked around in the code trying to find the issue, but I've come up empty handed. I can't run the debugger, because it's running remotely, and I can't debug locally because I can't reproduce the problem on my laptop (same version of MODx).

    System info follows:

    MODX version:      MODX Revolution 2.2.0-pl2 (traditional)
    ExtJS Version:     3.4.0
    Smarty Version:    3.0.4
    Database type:     mysql
    Database version:  5.1.56-log
    Database charset:  utf8
    PHP Version:       5.3.8
    


    Any help would be greatly appreciated!!
      • 34027
      • 30 Posts
      Bump.

      Anybody seen anything like this before?
        • 6038
        • 228 Posts
        Just got the exact same problem myself, and I suspect its a hosting issue to do with mod_security so I'm contacting the host now - will report back if it gets resolved.

        Did you manage to resolve it yourself?
          • 6038
          • 228 Posts
          As a followup, this definitely was a case of mod_security interference. After contacting the hosting company to get them to add a whitelist rule I still had problems in that the connector was now returning a 404 instead of a 403 eg:
          POST http://www.domain.com/connectors/workspace/packages.php 404
          After talking to them again, they confirmed it was again another mod_security issue, which they had to add a second rule for, and after that everything was good.
          I don't know exactly what changes or rules they put in place.
            • 34027
            • 30 Posts
            Yes, sorry for never following up - our provider removed mod_security, and things started working again.