We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 22840
    • 1,572 Posts
    Hi All,

    Just upgraded my live site from 2.0.7 to 2.2 latest and all packages and it's gone a bit wrong.

    For example wayfinder is refusing to populate most of the links in my navigation, it's outputting the pages etc just not the href part, this is also true of get resources which is outputting the page title and creating the link, just not populating the href.

    Get resources call:

    [[!getResources? &parents=`16` &showHidden=`1` &tpl=`list` &limit=`30` &depth=`0` &sortby=`pagetitle` &sortdir=`ASC`]]


    tpl content:

    <li><a href="[[~[[+id]]]]">[[+pagetitle]]</a> ([[getChildCount? &parent=`[[+id]]`]])</li>


    Al was working fine before the upgrade and I'm a bit baffled on to why wayfinder would only do 2 links but not the others, all are shown in menu and published.

    Ive cleared the cache via the admin and manualy, flushed sessions and permissions, cleared browser cache etc.

    Any help would be great and you can see the problems on the following:

    http://www.campsites-in-wales.co.uk/ = Top navigation not working apart from blog and campsites by location, the 8 latest campsites are not being populated.

    http://www.campsites-in-wales.co.uk/campsites-by-location.html ( this is the one with the call getresources call above on it to pull in the locations.

    Thanks
      • 22840
      • 1,572 Posts
      OK I've got the top navigation working again by going into those documents and re saving them in the manager and now there working.

      To test this on the other pages pulled in by get resources I've done the same on one of the locations and thats worked as well, so the question is is there anyway to do a mass save as theres around 300 documents on the site and it's going to be a nightmare having to edit and save them all.

      Just to specify I have deleted all the cache files so it's not that.

      Thanks
        • 22840
        • 1,572 Posts
        Also if I try to edit any of the actual campsites I'm getting the following in the manager

        Fatal error: Cannot redeclare class modTemplateVarInputRenderText in /home/paulple/public_html/core/model/modx/processors/element/tv/renders/mgr/input/text.class.php on line 10


        In the error log there is:

        [2012-01-15 10:00:38] (ERROR @ /connectors/element/tv.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 238


        EDIT

        This one has been resolved by going into all the TV's that were associated with the campsites and re saving them. First 2 are still un resolved though

        Thanks [ed. note: paulp last edited this post 14 years, 8 months ago.]
          • 22840
          • 1,572 Posts
          Right i've been in and edited all the pages so that the links are working and the site is now back to normal and working smiley

          when I viewed the error log it was over 11mb ( cleared it before I started editing the resources ) and it was just hundreds of the following:
           [2011-01-10 06:54:19] (ERROR @ /connectors/system/phpthumb.php) phpThumb was unable to generate a thumbnail for: /home/paulple/public_html/core/cache/phpthumb/phpThumb_cache_www.campsites-in-wales.co.uk_srcd8a5747a5893cee1ef75b2a461b7a467_par3c9237f62bc13d2d6cb6907137a1fa72_dat1291753554.jpeg
          [2011-01-10 06:54:19] (ERROR @ /connectors/system/phpthumb.php) Error outputting thumbnail:
          OutputThumbnail() failed because !is_resource($this->gdimg_output) in file "phpthumb.class.php" on line 557
          [2011-01-10 06:54:19] (ERROR @ /connectors/system/phpthumb.php) phpThumb was unable to generate a thumbnail for: /home/paulple/public_html/core/cache/phpthumb/phpThumb_cache_www.campsites-in-wales.co.uk_src77c24a16b9ff8224ef9ea7d86c23fd77_par3c9237f62bc13d2d6cb6907137a1fa72_dat1291753554.jpeg
          [2011-01-10 06:54:19] (ERROR @ /connectors/system/phpthumb.php) Error outputting thumbnail:


          I've cleared it again, browsed a page on the front of the site and edited 1 in the manager and theres now a load of errors again:

          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 10
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 14
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 15
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 239
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 16
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 17
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 18
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 19
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 20
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 21
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 22
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 23
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 24
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 25
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 26
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 27
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 28
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 29
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 30
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 31
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 32
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 33
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 34
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 35
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 36
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 37
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 38
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 39
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 40
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 41
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 10
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 14
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 15
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 239
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 16
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 17
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 18
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 19
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 20
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 21
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 22
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 23
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 24
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 25
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 26
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 27
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 28
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 29
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 30
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 31
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 32
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 33
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 34
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 35
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 36
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 37
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 38
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 39
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 40
          [2012-01-15 12:09:31] (ERROR @ /connectors/resource/index.php) Resource URI  already exists for resource id = 1; skipping duplicate resource URI for resource id = 41
          


          Anyone know what could be causing them as the error log will get massive again if I dont get them sorted.

          Thanks
            • 22840
            • 1,572 Posts
            Ok now sorted.

            For anyone else who was having the problem with those error messages I added a url alies to the home page, turned off friendly URL's, cleared the cache and then turned them back on.

            No more error messages yet smiley
              • 3109 ☆ A M B ☆
              • 894 Posts
              You could have avoided all that trouble if you upgraded your extras before upgrading then upgrade to 2.1.x then upgrade to 2.2.x since a lot of things were deprecated from 2.0.x to 2.1.x

              At least you sorted it out though which is good.
                Benjamin Marte
                Interactive Media Developer
                Follow Me on Twitter | Visit my site | Learn MODX
                • 22840
                • 1,572 Posts
                You could have avoided all that trouble if you upgraded your extras before upgrading

                Fantastic, where in the documentation does it state that? and why would it make a difference as long as everything was updated and the cache cleared?

                Yes I know there was a lot depreciated between 2.0 and 2.1 but the upgrade of all addons and MODX would have cured all that, I was only using standard addons like wayfinder and get resources, and from what I have read the upgrade from 2.0 to any updated versions only affect the core and a couple of addons that haven't been upgraded ( all that I have installed have been ).
                  • 38334
                  • 2 Posts
                  it doesn't matter if extras were upgraded before upgrading modx to 2.2.0.-pl2.
                  I've got the same "duplicate resource" bug and had to "republish" ALL pages on my site to get my site working. (by unpublishing and publishing all pages again and clearing cache in between) ((