Resurrecting this very old discussion in case my recent experience of having to install a ModX site on a windows server are helpful to anyone.
I experienced two issues that were making the resource browser unusable.
1. Thumbnails were extremely slow to load.
Tracing this back I discovered that ModX was being bootstrapped for every image request, which in itself seems unnecessary in the context of the browser. In every bootstrap phase instantiating the Database connection was taking over a second. This turned out to be down to the way in which windows handles the 'localhost' address, attempting to use IPv6 initial and then timing out after one second and falling back to IPv4. The quick fix for this issue is to alter your connection settings from localhost to 127.0.0.1 . Further issue on the root cause and alternative fixes here
http://stackoverflow.com/questions/11310564/php-to-easyphp-mysql-server-1-second-connection-delay/15436435
2. Subfolders intermittently fail to display.
When navigating the directory structure the tree would most often fail to refresh properly when opening certain folders. This turned out to be due to a fatal error in the ajax callback when checking file permissions. I hacked the core file /core/model/modx/sources/modfilemediasource.class.php to wrap the two calls to $file->getPerms() in an exception handling block.
try {
$octalPerms = substr(sprintf('%o', $file->getPerms()), -4);
} catch (Exception $e) {
$octalPerms = substr(sprintf('%o', '0000'), -4);
}