We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 38220
    • 6 Posts
    Just installed Modx 2.2
    Clicked Install, fine. Clicked Login, get the error message

    Fatal error: Call to a member function isAuthenticated() on a non-object in /websitePath/core/model/modx/modmanagerresponse.class.php on line 46

    Any ideas how to fix?

    Thanks in advance!
      • 22303 MODX Staff
      • 10,725 Posts
      See if you have any install error logs in core/cache/logs/ with the date of the install.
        • 38220
        • 6 Posts
        Yeah, I've got a load of errors...
          • 38220
          • 6 Posts
          Think it must be a bug with 2.2.0, I've installed 2.1.5 and that works fine.
            • 28215
            • 4,149 Posts
            Uhm, post the errors?
              shaun mccormick | bigcommerce mgr of software engineering, former modx co-architect | github | splittingred.com
              • 36211
              • 11 Posts
              Sorry to re-open an old post, but I'm receiving the exact same error as the original poster.

              I'm using v2.2.0 pl2, php v5.3.10, MySQL v5.2.35 and Apache v2.2.21 all running on Fedora 15. I've changed the SELinux context on the entire modxrevo directory structure before running install and setup the relevant ownerships and permissions. The web based install itself appears to go fine not producing any error messages at all, however, my log file (attached) contains a number of errors I'll admit to not understanding.

              Thanks In Advance [ed. note: trotskyicepick last edited this post 14 years, 6 months ago.]
                • 36211
                • 11 Posts
                Confused ;-( Just installed MODX Revo on an almost identical Ubuntu setup and all works fine. Pretty much the only difference is that Ubuntu isn't using SELinux. I can only assume that it's SELinux that might be causing the issue, but I have no idea as to why?
                  • 36211
                  • 11 Posts
                  Oh well, it seems I wasn't able to attach my error log, so I'll just do it the easy way andy paste it in. BTW, I no longer consider it to be an SELinux issue since I've now set the SELinux context on the entire modxrevo directory structure to "
                  unconfined_u:object_r:httpd_sys_content_rw_t
                  ". I'd had problems installing Drupal because of this and now that works, but I'd really like to be able to try MODX at work as well as at home.

                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not copy /var/www/html/modxrevo/core/packages/core/modContext/fec2ded11d3471a40c64d7d17dc51ed3/0/ to /var/www/html/modxrevo/index.php
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not copy /var/www/html/modxrevo/core/packages/core/modContext/fec2ded11d3471a40c64d7d17dc51ed3/1/ to /var/www/html/modxrevo/ht.access
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not copy /var/www/html/modxrevo/core/packages/core/modContext/ceb2f866bdca140a748ade0a6a080863/0/ to /var/www/html/modxrevo/manager/assets
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not copy /var/www/html/modxrevo/core/packages/core/modContext/ceb2f866bdca140a748ade0a6a080863/1/ to /var/www/html/modxrevo/manager/controllers
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not copy /var/www/html/modxrevo/core/packages/core/modContext/ceb2f866bdca140a748ade0a6a080863/2/ to /var/www/html/modxrevo/manager/templates
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not copy /var/www/html/modxrevo/core/packages/core/modContext/ceb2f866bdca140a748ade0a6a080863/3/ to /var/www/html/modxrevo/manager/min
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not copy /var/www/html/modxrevo/core/packages/core/modContext/ceb2f866bdca140a748ade0a6a080863/4/ to /var/www/html/modxrevo/manager/ht.access
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not copy /var/www/html/modxrevo/core/packages/core/modContext/ceb2f866bdca140a748ade0a6a080863/5/ to /var/www/html/modxrevo/manager/cache.manifest.php
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not copy /var/www/html/modxrevo/core/packages/core/modContext/ceb2f866bdca140a748ade0a6a080863/6/ to /var/www/html/modxrevo/manager/index.php
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/3e7f86249f358231f6dc4b3ff9533e82/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/874a12dbd01d2a45eadc80568c979fe0/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/ece347cbbcfad0e75b02a93458a742f1/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/d595a2ff2e73f57fbbcc1feceb4531cb/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/73a1fc3fad06065e0c84e2843a59b27a/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/38bcdfa9bcb81901314efd0759dc5232/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/5c428000323d1cbdde2031509d908f1d/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/b85ab445d10a8910a9f489b4388602b2/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/448c2936c27fe53935a37bc05d4e164f/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/259154d2fbc0012666469dd2387d334e/ to /var/www/html/modxrevo/connectors/
                  [2012-03-02 09:25:23] (ERROR @ /setup/index.php) Could not install files from /var/www/html/modxrevo/core/packages/core/xPDOFileVehicle/d730c41eb5013cf210713c2991874e80/ to /var/www/html/modxrevo/connectors/

                  So, that's it, like I've said before, the web install "appears" to run through OK, but I get the same errors when trying to access the site subsequently as the OP.

                  Thanks [ed. note: trotskyicepick last edited this post 14 years, 6 months ago.]
                    • 38290
                    • 712 Posts
                    I'm getting this error also when attempting to install 2.2.0 locally (although it a 2.2.0-dev branch). Makes it through setup completely ok, the font end pages work but attempting to log into the mgr results in a 500 error regardless of if hp_value date.timezone is set in .htaccess. MODX does write to the /core/cache directory but not an error log.
                    This is the error in my apache2 error_log:
                    [Fri Sep 28 12:51:09 2012] [error] [client 127.0.0.1] PHP Fatal error:  Call to a member function isAuthenticated() on a non-object in /Users/jP/Sites/deslib/core/model/modx/modmanagerresponse.class.php on line 44
                    [ed. note: dinocorn last edited this post 14 years ago.]
                      jpdevries