We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 12410
    • 353 Posts
    Hi Guys,
    after Upgrading 2.1.3 to 2.1.5 - I can no longer delete or add resources. I repaired and optimised all the database tables but no joy.

    PHP Version 5.2.17

    MySQL 5.0.77
    Any ideas please?

    Thanks
      • 22303 MODX Staff
      • 10,725 Posts
      Any additional details please? Error logs? JS errors in the browser? What happens when you try to Create a new Document or Delete an existing one? Maybe your file upload was corrupt if you uploaded the files individually over FTP?
        • 12410
        • 353 Posts
        Hi opengeek,

        I get this in the error log:

        [2011-12-29 13:45:24] (ERROR in xPDO::connect @ /myserverpath/httpdocs/core/xpdo/xpdo.class.php : 344) SQLSTATE[HY000] [2005] Unk[/i]nown MySQL server host 'mydatabasehostname' (2)
        [2011-12-29 13:45:25] (ERROR @ /connectors/element/chunk.php) Error preparing statement for query: SELECT `modSession`.`id` AS `modSession_id`, `modSession`.`access` AS `modSession_access`, `modSession`.`data` AS `modSession_data` FROM `modx_ session` AS `modSession` WHERE `modSession`.`id` = ?  - Array
        (
            [0] => 42000
            [1] => 1115
            [2] => Unknown character set: 'utf-8'
        )
        
        


        The issue is adding or deleting the resources in the menu tree in the manager. When i right click a resource in the menu tree it asks do i want to delete it and when i click yes nothing happens.

        My config file uses
        $database_connection_charset = 'utf-8';


        No JS errors as far as i can see. No luck reuploading manager folder either.
        Thanks [ed. note: howster last edited this post 14 years, 9 months ago.]