Help!
I have problems with Access Controls. As soon as I create a new Resources Group and assign Resources to it, the anonymous user (normal website's visitor) can't see the website, it appears the message (on the front end):
. . . . . . . . . . . . . . . . . . . . . . . . . . . .
500 Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, XXXX.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
(end of the message)
. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
What I did:
On Resources Group I made a new one: "Website Visitor" with all the resources on it that should be available for everybody who visits the site.
On Access Control, I upgraded the User Group: (anonymous), and on the tab: "Resource Group Access" assigned to it the "Website Visitor" resource group.
Then, on Security flushed permissions and all sessions. On other browser I want to see my website and receive the above mentioned error message.
I don't know if the next is related to the same problem.
On Access Controls / Access Policies I want to update a Policy by enable one function and the CMS can't save the changes. For example, I check the box "enable" for edit_chunk and click on save and the window "Please wait. Saving…" appears but I don't receive and confirmation message and the changes are not saved.
Please help me.
My system info:
MODX Revolution 2.1.5-pl (traditional)
DB: mysql 5.0.92-community utf8
PHP Version: 5.2.17
That's an odd one. What happens when you try to visit a non-existent page in the front end?
Does the host provide a 404.shtml document that might be missing from the MODX root directory?
Hi Bob, thanks for answer,
I receive an error message when trying to reach a non existing page on the root directory:
. . . . . . .
Not Found
The requested URL /sadasd was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
. . . . . .
Estrange, because i DO have an error (404) page on root and configured on the system settings error_page with the right ID of the document
Yes, but is there a *file* on the server called 404.shtml in the MODX root directory (not a MODX document)?
[ed. note: BobRay last edited this post 14 years, 9 months ago.]
Nope, there is no such a file on root directory.
Look around on the server, (try public_html). If you find it, copy it to the MODX root directory.