My site is blank. The Manager is fine. All appears to be working except the site.
Upgraded two sites from MODX 2.1.3 to 2.2RC2. One with multiple contexts works; it displays all 3 contexts as expected.
It's this other single context site that isn't displaying the front end. Plain old white blank page.
I forget what this might be solved with. Help me remember, please.
Thanks.
-
☆ A M B ☆
- 756 Posts
Clear your site cache folder ({root}/core/cache/) and they try again.
Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
Visit
CharlesMx.com for latest news and status updates.
I did that before I ran setup. In the past when I neglected to delete all core/cache/ files, it affected the Manager only.
-
☆ A M B ☆
- 756 Posts
Did you review your ModX error log and web server error log?
Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
Visit
CharlesMx.com for latest news and status updates.
-
MODX Staff
- 10,725 Posts
The initial error you posted is not a problem, but something else is causing your webserver to return a 500 error; likely a FATAL PHP error that is being logged somewhere else or not at all (because it may be crashing the web server and be unable to report it).
I don't know where to begin. I restarted the server, figuring that might help, but not really because I have 2.2RC2 on 2 sites.
Site #1 is working. It was an upgrade from 2.2rc1. Site#2 - the one not working on the front end at the topic of this thread - was an upgrade from 2.1.3 to 2.2RC2. Both were traditional installs. I followed the same procedure for each.
-
☆ A M B ☆
- 756 Posts
What about pushing up all the files for the upgrade (or install you did) and then re-run the setup process, often when using FTP and transferring that number of files something goes haywire and simply re-pushing the files clears the error.
Evo Revo // Ubuntu, CentOS, Win // Apache 2x, Lighttp (Lighty)
Visit
CharlesMx.com for latest news and status updates.
Could be, but I'm so sick and tired up FTPing, then unZipping, then this and that. I am FTPFatigued, even moreso when another domain on the same server has no errors of any kind, not even to the various contexts.
I tried reinstalling and then doing a fresh install on the same database with a different prefix of course.
Nothing.
I created a new database and then installed 2.2RC2 into a subdomain. Worked.
Must be something wrong with that database? Got corrupted somehow?
Anyways, I'm dropping this issue.