On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • my choose-language menu' doesn't work in the images pages generated with maxigallery: its url don't have the final "?pic=64" part, as an exhample, on the english page
    http://mysite.com/en/gallery01.html?pic=64
    I have the italian flag pointing to
    http://mysite.com/it/gallery01.html

    that's the thumbnail page, instead of
    http://mysite.com/it/gallery01.html?pic=64
    that's the italian version of the same picture.
    AND, even worst, the "manage picture" button gives a blank page
    Help please.
    Thank you
      MODx evo 1.5~1.6 ✪ Apache v 2.2.22 ✪ PHP v 5.3.10 ✪ MySQL v 5.1.61
      <°'iiii);
    • I tryied this code:
      (yams_docr)[+maxigallery.picture.id:isnot=``:then=`?pic=[+maxigallery.picture.id+]`+]
      wich works in the page, but points on the same language (the page itself)
      To have it pointing to the other language page I then tryied to put the link in the template of my language list menu, made as in http://forums.modx.com/thread/45571/yams-languages-list-amp-classes#dis-post-263730"" target="_blank" rel="nofollow">language list generation, and there the final part (?pic=64) is lost again.
      My idea is that the yams menu is processed before the maxigallery snippet, so it's unaware of the current page.
      Any help?
      Thank you
        MODx evo 1.5~1.6 ✪ Apache v 2.2.22 ✪ PHP v 5.3.10 ✪ MySQL v 5.1.61
        <°'iiii);