We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37902
    • 2 Posts
    The front end of one of our ModX sites is somehow "crashing" in that we only get a blank page if we browse to it. If we go into the manager and clear the cache, it starts working again. (We've verified the permissions are correctly set.) We can't find a common issue in the server logs or the ModX error logs.

    We're running:
    MODx Revolution 2.0.8-pl (traditional)
    PHP Version 5.2.17
    mysql 5.0.91
    GoDaddy hosting

    I've done a Google search and a search on these boards and tried all the items suggested that I can find to no avail. Does anyone have any ideas?
      • 33983 ☆ A M B ☆
      • 181 Posts
      Is error logging set in the PHP ini? Can you edit the php ini file or settings? If so try to change the display_errors setting to on: http://us3.php.net/manual/en/errorfunc.configuration.php#ini.display-errors. Then run view your site. I would guess you have a snippet that has a parse error which is fatal and the MODX error log will not report on fatal errors and if you don't have the error log set up to run you will not find it.
        • 22303 MODX Staff
        • 10,725 Posts
        This was a known issue in 2.0.x releases; at times the cache files could become corrupted when multiple threads attempted to write the file at the same time. This has been resolved in 2.1+ via proper file locking.
          • 37902
          • 2 Posts
          Based on our searches, we thought 2.0.8 fixed the problem. We started moving the site to 2.1.something, so I guess we'll just keep going down that path. Thanks!