The front end of one of our ModX sites is somehow "crashing" in that we only get a blank page if we browse to it. If we go into the manager and clear the cache, it starts working again. (We've verified the permissions are correctly set.) We can't find a common issue in the server logs or the ModX error logs.
We're running:
MODx Revolution 2.0.8-pl (traditional)
PHP Version 5.2.17
mysql 5.0.91
GoDaddy hosting
I've done a Google search and a search on these boards and tried all the items suggested that I can find to no avail. Does anyone have any ideas?
-
MODX Staff
- 10,725 Posts
This was a known issue in 2.0.x releases; at times the cache files could become corrupted when multiple threads attempted to write the file at the same time. This has been resolved in 2.1+ via proper file locking.
Based on our searches, we thought 2.0.8 fixed the problem. We started moving the site to 2.1.something, so I guess we'll just keep going down that path. Thanks!