We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33982 ☆ A M B ☆
    • 476 Posts
    So MODx 2.2 is really exciting...love the new features and UI improvements. For sure the most I've been excited about MODx in awhile.

    3 bugs I ran into before MODx Revo just stopped working altogether:


    • 1. Here's the first one: https://forums.modx.com/thread/71892/modresource-is-default-content-type
    • 2. Template and Chunk static resource. Probably one of my favorite new features. When choosing "Static Resource", the ability to navigate to the static file on the server worked. When I found it, it would slurp it into the db, but upon save, nothing would happen (it wouldn't save in).
    • [li]3. So I was able to work around point 1 and 2 above, but finally it Revo just died altogether. It gave me this message finally at the very top:
    [2011-11-23 15:24:15] (ERROR @ /All_Fired_Up/manager/index.php) Could not find action file at: controllers/default/index
    and in the right pane it gave me this message: Could not find action file at: controllers/default/index.php[/code
      ][/li]

    Hopes this help...
    I'm working on MAMP 1.7.1
    PHP Version 5.2.5

    Please let me know if you need anymore info.
      Precision Web Development ... SmashStack.com
      • 38354
      • 4 Posts
      I also have this problem too in the right pane:
      Could not find action file at: controllers/default/index.php


      I'm working on ubuntu 11.10 x64 with apache 2.2.2 and php 5.3.6 and mysql 5.1.58 [ed. note: meshkov last edited this post 14 years, 8 months ago.]
        • 37850
        • 4 Posts
        Sounds like a cache inconsistency to me. Try removing the entire contents of the core/cache folder.
          • 38552
          • 17 Posts
          Quote from: ryardley at Jan 26, 2012, 03:56 AM
          Sounds like a cache inconsistency to me. Try removing the entire contents of the core/cache folder.

          Just thought I should report in and confirm that removing the contents in the core/cache folder solved the problem. Thank you.
            • 1061
            • 81 Posts
            Today I had the same error, for the first time for half of year.
            Could not find action file at: controllers/default/index.php


            Version: 2.2.2
            Server: Apache/2.2.17 (Unix) PHP/5.2.14

            Clening the cache solve the problem.
            May be because the two editors at the same time working in the backend. [ed. note: alex_dutch last edited this post 14 years, 2 months ago.]
              • 21106
              • 53 Posts
              I'm having the same problem.

              I tried clearing the cache but it's still there. Any thoughts guys? (The site has ran for more than a year without encountering this problem.)

              Version: 2.2.6
              PHP: 5.2.17

              I have two other websites running on 2.2.6 and 2.2.4 on the same server. Both works perfectly. Any idea?
                • 3749
                • 24,544 Posts
                Did you manually delete all the files in the core/cache folder?
                  Did I help you? Buy me a beer
                  Get my Book: MODX:The Official Guide
                  MODX info for everyone: http://bobsguides.com/modx.html
                  My MODX Extras
                  Bob's Guides is now hosted at A2 MODX Hosting
                  • 21106
                  • 53 Posts
                  Quote from: BobRay at Jan 26, 2013, 12:17 AM
                  Did you manually delete all the files in the core/cache folder?

                  Yes, I did. (3 times already) Same problem. Should I just re-install?
                    • 3749
                    • 24,544 Posts
                    Re-installing can't hurt. If you transferred the files individually with FTP, you could have a corrupted of missing file. It happens fairly often when you use that method.

                    Here are some things to try first, if you haven't already:

                    * Turning off the compress_js and compress_css System Settings
                    * Clear your browser cache *and cookies*. A leftover cookie can cause all kinds of weirdness.
                    * Disable all plugins. A plugin that throws an E_NOTICE error can crash MODX silently if PHP is upgraded by the host.

                      Did I help you? Buy me a beer
                      Get my Book: MODX:The Official Guide
                      MODX info for everyone: http://bobsguides.com/modx.html
                      My MODX Extras
                      Bob's Guides is now hosted at A2 MODX Hosting