-
☆ A M B ☆
- 2,475 Posts
This is probably an issue with your environment. What version of PHP, MySQL, and what browser are you using? Where is this being hosted? Do you have all the required PHP modules installed? When and how exactly does this fail?
It fails on the Database Screen. When I select 'Create or test selection of your database' I am told that the prefix modx_ is already in use with the database. This is because the default values from the script are being submitted rather than the form values entered in the previous step. So the script always connected to the modx db with a prefix of modx_. To complete the install I edited the config values. Only thing that is unusual about my server is that there is no passowrd for root with mysql as it is a local dev server.
Environment details:
Mac OSX 10.6.4
Apache 2.2.15 (Unix)
PHP 5.3.8-ZS5.5.0
MySql 5.1.54
MODx 2.1.5-pl traditional
Safari 5.0.3 (6533.19.4) (but also Firefox 4.0.1)
-
☆ A M B ☆
- 2,475 Posts
Hmmm.... I've installed 2.1.5 with a custom db prefix. Are you sure your database doesn't contain tables with the "modx_" prefix? If it finds any, the script will fail.
The database had no tables in it. I only had a quick look at the scripts to solve the immediate problem, but it did appear to me that the form in the tpl files is submitting values like 'database_user' and 'dbase' whilst the $_POST values being checked in the script for the same fields are 'databaseloginname' and 'database_name'. But this has turned out to be a red-herring as the form is actually submitted by ajax and 'database.js' grabs the form values and submits them to the processor.
You could be right, it might be an environment/browser thing - if I get time I'll look further into it - Thanks for your interest.
Check the db name in core/config/config.inc.php to make sure it's connecting to the DB you think it is. I've been burned by this a couple of times.