Hi,
I'm attempting to install Revo 2.1.5 on Ubuntu 11.10 running MySQL 5.1.58, PHP 5.3.6 with Suhosin patch. During setup, I can succesfully connect to the database. However, the connection character set and collation dropdown boxes are both blank. I've ensured that utf8 is set as the MySQL character_set. What further steps must I take to ensure that Revo setup "sees" the charset and collation settings? Once this is resolved, will setup then be able to create my DB?
Thanks,
Sid
-
☆ A M B ☆
- 2,213 Posts
I suspect suhosin may be interfering with the install. Can you disable it (
http://myeasylinux.wordpress.com/2010/10/25/disable-suhosin/) and try running the install again. You should be able to re-enable it after the install finishes.
I disabled it via php.ini. Do I need to do a httpd restart for this to take effect?
Thanks,
Sid
-
☆ A M B ☆
- 2,213 Posts
No, the affect should be instant.
I added those entries to php.ini and restarted apache2. However, when I do php -v I still see PHP 5.3.6 with Suhosin Patch (cli). What other steps must be taken?
Thanks,
Sid
-
☆ A M B ☆
- 2,213 Posts
Did you try running the installer again?
Yes. Character set and collation dropdown are still blank and same messages are given.
-
☆ A M B ☆
- 2,213 Posts
I made the suggested change. Now, when I test the database, I receive this new error:
Connecting to database server:
Could not connect to the database server. Check the connection properties and try again.
[2011-11-23 15:15:03] (ERROR in xPDO::connect @ /var/www/modx/core/xpdo/xpdo.class.php : 344) SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using password: YES)
-
☆ A M B ☆
- 2,213 Posts
Do you have any control panel installed on this server? Also please double check your username and password, the above error indicates an error with such.