Okay, I think I got this solved. I noticed that eAccelerator was turned on and session.auto_start was turned off in phpinfo, so I modified my php.ini files with:
session.auto_start = 1;
eaccelerator.enable = 0;
eaccelerator.optimizer = 0;
eaccelerator.debug = 0;
After doing this, I got a Fatal Error: PDO not found, so then I added this to my .ini:
extension=pdo.so;
extension=pdo_mysql.so;
The error went away, but I was still being redirected back to login. When I went to compare this server's phpinfo with a working version, I noticed in the working version, session.auto_start was OFF (which is what I would have known if I had paid more attention to the trouble-shooting section), so I revised my .ini files and now it seems to be working (crossing my fingers). This is my final .ini setup:
session.auto_start = 0;
eaccelerator.enable = 0;
eaccelerator.optimizer = 0;
eaccelerator.debug = 0;
extension=pdo.so;
extension=pdo_mysql.so;
session.cookie_lifetime = 0;
#EDIT 1: Make sure to place the .ini file in all your subfolders, and clear the core/cache. Otherwise, the manager will throw javascript errors all over the place...
#EDIT 2: The workaround above got me access to the manager, but that's about it. My Superuser account doesn't have permissions to do anything. I keep getting "access denied" errors for just about everything. Looks like I'm stuck with Evo for now *sigh*.
#JMHO: I love MODX Revo, but this system is WAY too dependent on having the server environment just-so for everything to work right. PHP environments are as different as the people that configure them, so creating such a fickle system seems like the wrong direction to go. However, the system, when it is working (and I've noticed a LOT of people have been having issues), is BRILLIANT.
[ed. note: dansig71 last edited this post 14 years, 10 months ago.]