We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 37779
    • 3 Posts
    I recently installed MODx 2.1.5 on a Godaddy hosted account and it worked perfectly. I just tried installing the same version on some of my own reseller hosted accounts (HostDime, see versioning below), and it too installed without a hitch and everything looked fine in the config files, etc. BUT...

    When I log in with my admin account, it validates (I tried incorrect user and password and it comes back with an error), but always displays the login screen again without an error message. I looked in login.php and modmanagerrequest.class.php where the login is processed, and added some debug code to it. In login.php, it get's past the username and password validation part fine and then does a "sendRedirect" back to manager/index.php, but in the modmanagerrequest.class.php file at line 100, the following code returns true:
    if (!isset($this->modx->user) || !$this->modx->user->isAuthenticated('mgr')) {


    ...and thus displays the login page.

    I've tried all the previous suggestions (delete cache and cookies, remove the "session_" system settings, delete the core/cache files. I've tried setting the cookie domain and path. I'm at a loss. There is something with this particular setup that is causing the sessions to fail.

    ANY HELP/IDEAS would be greatly appreciated!

    Setup:
    Apache 2.2.11
    PHP 5.2.9
    MySQL 5.0.91
    MODx 2.1.5pl [ed. note: dansig71 last edited this post 14 years, 10 months ago.]
      • 37779
      • 3 Posts
      Okay, I think I got this solved. I noticed that eAccelerator was turned on and session.auto_start was turned off in phpinfo, so I modified my php.ini files with:

      session.auto_start = 1;
      eaccelerator.enable = 0;
      eaccelerator.optimizer = 0;
      eaccelerator.debug = 0;


      After doing this, I got a Fatal Error: PDO not found, so then I added this to my .ini:

      extension=pdo.so;
      extension=pdo_mysql.so;


      The error went away, but I was still being redirected back to login. When I went to compare this server's phpinfo with a working version, I noticed in the working version, session.auto_start was OFF (which is what I would have known if I had paid more attention to the trouble-shooting section), so I revised my .ini files and now it seems to be working (crossing my fingers). This is my final .ini setup:
      session.auto_start = 0;
      eaccelerator.enable = 0;
      eaccelerator.optimizer = 0;
      eaccelerator.debug = 0;
      extension=pdo.so;
      extension=pdo_mysql.so;
      session.cookie_lifetime = 0;


      #EDIT 1: Make sure to place the .ini file in all your subfolders, and clear the core/cache. Otherwise, the manager will throw javascript errors all over the place...

      #EDIT 2: The workaround above got me access to the manager, but that's about it. My Superuser account doesn't have permissions to do anything. I keep getting "access denied" errors for just about everything. Looks like I'm stuck with Evo for now *sigh*.

      #JMHO: I love MODX Revo, but this system is WAY too dependent on having the server environment just-so for everything to work right. PHP environments are as different as the people that configure them, so creating such a fickle system seems like the wrong direction to go. However, the system, when it is working (and I've noticed a LOT of people have been having issues), is BRILLIANT. [ed. note: dansig71 last edited this post 14 years, 10 months ago.]
        • 3749
        • 24,544 Posts
        Your trouble in the Manager is most likely due to directory permissions.

        Generally these directories have to be writable:

        core/cache
        core/packages
        core/components
        assets/components

        The most likely culprit at this point is core/cache.
          Did I help you? Buy me a beer
          Get my Book: MODX:The Official Guide
          MODX info for everyone: http://bobsguides.com/modx.html
          My MODX Extras
          Bob's Guides is now hosted at A2 MODX Hosting
          • 37779
          • 3 Posts
          Thank you BobRay, I will make sure to check this next time. Unfortunately, due to time constraints, and since this is basically a brochure site anyway, I fell back to Evo for this project.

          I am curious, though, I wonder why such a sophisticated system wouldn't alert me that my cache directories aren't writable? [ed. note: dansig71 last edited this post 14 years, 10 months ago.]
            • 3749
            • 24,544 Posts
            I'm not that familiar with the install code, so I don't have a good answer for you, but it's a good question. wink

            You could file that as a feature request here if it hasn't been done already: http://bugs.modx.com
              Did I help you? Buy me a beer
              Get my Book: MODX:The Official Guide
              MODX info for everyone: http://bobsguides.com/modx.html
              My MODX Extras
              Bob's Guides is now hosted at A2 MODX Hosting
              • 32862
              • 10 Posts
              This does not appear to be solved. I am having the same issues and I have changed no variables or added anything. It just stopped working!

              2.1.3

              Any additional help would be great!