Hi, Just wondered if anyone knows of any reason a site would stop working after a PHP upgrade to 5.3? Our host upgraded the server yesterday. There are a number of issues but specifically, I can no longer log into the manager (returns an error even though the details are correct). I have rebuilt the site locally on MAMP and if i use PHP 5.2.7 it functions correctly, switching to PHP 5.3.6 replicates the error i see on the production server. Help!
Check the content of the error log by looking at the file: core/cache/logs/error.log. It may provide some clues.
-
☆ A M B ☆
- 24,524 Posts
It would help if we knew what error you're getting.
Just to let you know, the error was due to $database_connection_charset being blank. Thanks for replying.
-
☆ A M B ☆
- 24,524 Posts
Interesting; I was just developing a new design and upgrade for a client, using a subdirectory installation and the same database with different table prefix for the development installation. I was doing a lot of copy/pasting from the old (0.9.6.2) version's content to the new one, and all the utf8 special characters (multilingual site) were coming back as ?. Then I realized I had copy/pasted the database part of the old config.inc.php file to the new one, and the $database_connection_method = 'SET CHARACTER SET' line was missing. As soon as I added that line to the new config.inc.php file, everything pasted in just fine.