Hi guys, I am getting some error messages in my log that look like this:
[2011-10-18 19:04:52] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/formit/properties
[2011-10-18 19:06:50] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/formit/properties
[2011-10-18 19:06:50] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/formit/properties
[2011-10-18 19:06:50] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/formit/default
[2011-10-18 19:23:50] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/formit/properties
[2011-10-18 19:23:50] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/formit/default
[2011-10-18 19:23:50] (ERROR @ /index.php) Could not cache resource 109
[2011-10-18 19:25:03] (ERROR @ /index.php) Could not cache resource 109
and my login/logout functionality is a little buggy. Sometimes it works, sometimes it does not. Also, my Wayfinder menu behaves oddly as well. For instance, at random times, my dropdown menus will show only 1 of 7 child pages, sometimes 3.
I've done a few sites already in Revo, but I'm not a webmaster or a PHP guru. Can anyone perhaps suggest what might be causing this problem. I'm guessing something did not install correctly. Any ideas?
This site is on a Media Temple gridserver.
Thanks in advance
Make sure your core/cache directory is writable.
Hi BobRay, thanks for your multiple replies (other threads). Core/cache is/was writable. I'll see if the error keeps happening or not and repost here. Thanks
I wonder if that could be a character set issue, since there's no problem caching other files. Check the database in PhpMyAdmin and make sure all the files and fields are in the same character set as the one specified in core/config.config.inc.php. If not, see this:
http://bobsguides.com/convert-db-utf8.html
I think the Wayfinder problem is due to a bug in version 3.2.3 of Wayfinder. You could revert to a previous version or wait for a fix.
Hi bob, I will give that a try thanks...here is todays error log with some new items:
[2011-10-27 11:19:48] (ERROR @ /connectors/element/propertyset.php) Error caching lexicon topic lexicon/en/core/default
[2011-10-27 11:21:56] (ERROR @ /connectors/system/phpthumb.php) phpThumb was unable to generate a thumbnail for: /nfs/c09/h03/mnt/135277/domains/elizabethgrady.edu/html/core/cache/phpthumb/phpThumb_cache_elizabethgrady.edu.s135277.gridserver.com_src68157b3900e7cfe98fc94f870042ec53_paradf896d45f319fa323d889e84ccb98c5_dat1317237433.jpeg
[2011-10-27 11:21:56] (ERROR @ /connectors/system/phpthumb.php) Error outputting thumbnail:
OutputThumbnail() failed because !is_resource($this->gdimg_output) in file "phpthumb.class.php" on line 557
[2011-10-27 11:24:21] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/formit/properties
[2011-10-27 11:24:21] (ERROR @ /index.php) Error caching lexicon topic lexicon/en/formit/properties
[2011-10-27 11:24:21] (ERROR @ /index.php) Error caching script elements/modsnippet/2
[2011-10-27 11:24:22] (ERROR @ /index.php) Could not cache resource 109
[2011-10-27 11:24:22] (ERROR @ /index.php) Could not cache resource 109
Hi Bob, when I log into PhpMyAdmin and select the database, all of the tables have this col:
latin1_swedish_ci
So i guess I am screwed?
Click on the link I gave you in the previous message. You're not screwed, but you're definitely inconvenienced.
Did you check the character set in config.inc.php? If it isn't utf-8, you may be OK (though didn't you say you were having trouble already?).
Bob's Guides ran for a long time with a mismatched character set before I got around to doing the utf-8 conversion described on the site. It's not usually a problem if you don't have any strings with non-English characters in them. Have you translated any of the characters in the FormIt property set? It might be worth just uninstalling and removing FormIt and re-downloading/re-installing it to see if that helps.
That said, the conversion is not as bad as it sounds -- it's just a matter of following all the steps). You could hire me, but because I'm so busy, I'm ridiculously expensive and it might not cure the errors in the log.
yes, I checked the config file, and it is utf-8. All the db tables are the latin_swedish though.
I'll try uninstalling/reinstallling FormIT. I have not translated any of the characters. Don't even know how to do that.