I have set up the crontab on my server properly. But when I run the cron.php file in ssh I get the following error:
Parse error: syntax error, unexpected T_STRING in /home/content/93/2045293/html/assets/components/cronmanager/cron.php on line 29
But I do not see an error anywhere in the file. I am using revo 2.1.3.
[ed. note: Lacks_Imagination last edited this post 15 years ago.]
I solved the problem by running cron.php using PHP 5. I was running the file in PHP 4 before.
-
☆ A M B ☆
- 1,231 Posts
I cannot get this to work with modx 2.1.3 advanced.
The email I receive has the following error.
<br />
<b>Warning</b>: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cookie - headers already sent in <b>/home/site/core/model/modx/modx.class.php</b> on line <b>1975</b><br /> <br />
<b>Warning</b>: session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /home/site/core/model/modx/modx.class.php:1975) in <b>/home/site/core/model/modx/modx.class.php</b> on line <b>1975</b><br />
I suppose I dont have to input any login for server since all pages are online, but the cron manager doesnt seems to work...