We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36926
    • 701 Posts
    I've installed revo a number of times, but on occasions i've had it where i get a blank page right at the end of the wizard just before the page where you check to delete the setup folder.

    It had baffled me for a while and I'd never found a solution in the forums and i was always installing on the same hosting setup. Today i finally solved it and i'm posting as maybe of some use to someone.

    I was using my host to generate an auto password for my install and sometimes they'd add a ' in the password, which was breaking the config file. So for example the password generated would be:

    pass'word

    and the core/config.inc.php file would have:
    $database_password = 'pass'word';
    


    Which was then resulting in a syntax error on the page.

    Hopefully helps someone.

    Ben
    [ed. note: bennyb last edited this post 15 years ago.]
      • 18373 ☆ A M B ☆
      • 3,141 Posts
      Mark Hamstra Reply #2, 15 years ago
      What version of MODX are you installing? And are you using a manual install or an install script provided by your host that creates the database credentials?
        Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

        Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
        • 36926
        • 701 Posts
        Latest Revo install (2.1.3), but i've had the issue on all version. I'm using a manual install, so I manually set up the database first and get an a auto generated password when creating the DB within the hosting conrol panel. Of course the password is normally more complex then the example above. eg *r@3$&'^ so I've not paid much attention to the characters.

        I'll noticed the error when i viewed the config file in my editor and had a syntax error.

          • 22303 MODX Staff
          • 10,725 Posts
          It would be great to see a ticket for this issue. smiley
            • 36926
            • 701 Posts
            Quote from: opengeek at Sep 21, 2011, 10:04 AM
            It would be great to see a ticket for this issue. smiley
            Issue added
              • 3749
              • 24,544 Posts
              Good catch. I put it in the Installation FAQ at Bob's Guides. Thanks!
                Did I help you? Buy me a beer
                Get my Book: MODX:The Official Guide
                MODX info for everyone: http://bobsguides.com/modx.html
                My MODX Extras
                Bob's Guides is now hosted at A2 MODX Hosting