We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36959
    • 22 Posts
    Hi there,

    I am currently having problem uploading images to the Gallery albums and would like to seek help here.

    As you know Gallery provides 3 ways of uploading images, they are:
    1. Upload Item - upload a single image file
    2. Batch Upload - upload a folder that contains multiple images
    3. Zip Upload - upload a zipped file that contains multiple images

    In my case #1 and #3 don't work at all, when doing single image file upload, despite I have specified a local file on my workstation (note that my web server is somewhere on the Internet), the upload will failed with error message "Please specific a file to upload" returned. The zip upload will always failed with "Access denied" error returned. Note that I am aware of the bug that zipped file needs to be created by zipping a folder instead of zipping a number of images directly.

    "Batch upload" is the only one that partially works. However, if only works if you specified an image folder that is local to the web server. My web server is remote to me as I mentioned, therefore I would like to be able to upload an image folder that is local on my workstation instead of the web server, sadly that doesn't work at all, and no error message returned, simple the upload dialogue box would highlighted the "Directory" box in red as if I didn't enter a valid path.

    Has anyone of you guys come across this and what would be the cause?

    Regards.
    Johnmen

    This question has been answered by johnmenz. See the first response.

      • 3749
      • 24,544 Posts
      It sounds like your host has allow_url_fopen turned off.

      You can try putting this in your php.ini file if the host allows it:

      allow_url_fopen = On
        Did I help you? Buy me a beer
        Get my Book: MODX:The Official Guide
        MODX info for everyone: http://bobsguides.com/modx.html
        My MODX Extras
        Bob's Guides is now hosted at A2 MODX Hosting
        • 36959
        • 22 Posts
        Hi BobRay,

        Thanks for the reply. I have run "php -i | greg fopen" and I got this output:
        allow_url_fopen => On => On

        And I have checked the php.ini and can confirm the option you mentioned is turned on.

        Regards.
        Johnmen [ed. note: johnmenz last edited this post 15 years ago.]
          • 36959
          • 22 Posts
          Hi there,

          No one knows what the problem is? Splittingred, appreciate if you have time to have a look at this.

          Regards.
          Johnmen
            • 20215
            • 144 Posts
            Set upload_tmp_dir to a directory if it is not
              ----------------------------------
              canale irc Italiano #modx server: tophost.azzurra.org
              • 36959
              • 22 Posts
              Thanks for the reply. Where do I find the "upload_tmp_dir" please? I tried looking for it from the "system settings" but didn't have luck.

              Regards.
              Johnmen
              • discuss.answer
                • 36959
                • 22 Posts
                Hi there,

                With the latest release of version 1.3 for Gallery, it provides an additional upload method "multiple upload" which is working for me. Therefore I have 2 ways that work, "multiple upload" and "batch upload", I am prepared to live with that.