We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36517
    • 14 Posts
    Hi,

    I am getting a 500 error when I get to setup/index.php?action=install while I am attempting to upgrade to REVO from EVO. I have deleted cache files and cleared browser cache, checked php version and memory. I backed up my cache folder and here is some of what was in the error log (the most recent time I tried to do this).


    [2011-09-15 14:00:29] (ERROR @ /index.php) Error 42S22 executing statement:
    Array
    (
    [0] => 42S22
    [1] => 1054
    [2] => Unknown column 'modSystemSetting.key' in 'field list'
    )

    [2011-09-15 14:00:29] (FATAL) Could not load core MODX configuration!


    Here are some of the details of the server:

    Apache/1.3.41 (Unix) PHP/5.2.17 mod_psoft_traffic/0.2 mod_ssl/2.8.31 OpenSSL/0.9.8b mod_macro/1.1.2
    MySQL client version: 5.0.67

    Oh and here is what the MySQL server info is:

    Server: Localhost via UNIX socket
    Server version: 5.0.90-log
    Protocol version: 10
    MySQL charset: UTF-8 Unicode (utf8)

    So it seems the server and client versions of MySQL are different ... apparently that's bad:

    Those should match; this means PHP was compiled against a different mysql client library than the mysql server, and this is a frequent source of problems with PDO.

    From: https://forums.modx.com/thread/12054/error-preparing-statement-when-installing-revo-beto-4#dis-post-68529
    [ed. note: kblair last edited this post 15 years ago.]
      • 1343 ☆ A M B ☆
      • 2,213 Posts
      Hello,

      There is NOT a direct upgrade route from Evolution to Revolution. You need to use provisioner (for smaller sites) to upgrade, as page numbers may shift, or for larger sites do a manual upgrade (or hire someone to do so).

      If you need help with this contact me and I can help you.
        Patrick | Server Wrangler
        About Me: Website | Tweets |  MODX Hosting
        • 36517
        • 14 Posts
        I ended up doing in manually - basically, creating the new site and adding all of the elements / resources in PHPmyadmin. This is what I did to set up my test environment, and it worked fine that time, but now I can't edit any of the resources I've added that way - it's just "saving''. I can create new resources just fine though, so I assume that modX is unable to edit those DB records. How can I fix this?
          • 22303 MODX Staff
          • 10,725 Posts
          Adding the data via PHPMyAdmin is going to be very difficult unless you know all the new fields and relations to populate for Revo. I would recommend adding the Resource and Elements via the manager interface or looking into Provisioner.
            • 36517
            • 14 Posts
            I did look into Provisioner, but I get login errors - looking into that with Shablett's help.

            As far as all the fields populating correctly it seemed to work relatively well (with a few oddities / incorrectly populated info) when I did it to set up the test environment. I just added empty fields to make the numbers of columns consistent and dealt with changing around references to templates etc in the manager interface after I got the data in.

            To move to the live server, I had all the information on the test environment DB (which I populated via phpMyAdmin in the first place), and for anything that had changed since I created the text environment I just repopulated that content item, and left everything else from the revo db I was working on for the test.

            Since it worked relatively well going from evo->revo via phpmyadmin, I think I'll try clearing fields in case one of the settings from the other install is preventing the manager from saving correctly ...

            And otherwise I'll just use provisioner once that's working to move elements from test -> live in future.
              • 36517
              • 14 Posts
              I can't use revisioner because I'm using the most recent version of MODx. So there's evidently no other way of migrating my content except via the database (or manually).


              I am currently unable to save any of the resources that I migrated from MODx 2.1.3 (test) to 2.1.3 (live). Since I was migrating dbs from one modx install of the same version to another, I don't think that it's a conflict between db structures (column numbers etc). I suspect it's more likely that some value from my other install is confusing my new install, because it's expecting some other value.

              It does not throw an error; the "saving" box just comes up and never completes.

              I did get my host to check permissions on the DB user and the user I have configured for MODx is an admin user and has all permissions.

              Is there some existing issue like this? Does anyone know why this will be happening?

              If no one knows what my problem might be, could anyone tell me where the SQL is built to save to the DB? If I can look at that I might be able to tell what the issue is.