We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 23571
    • 223 Posts
    Using Revo 2.1.3-pl am getting an error when I attempt to delete an image using the MODX Resource Browser. It says "Please specify a valid directory.: /var/www/vhosts/mydomain.com/httpdocs/assets/Images/undefined/mypic.jpg"

    The "undefined" is being inserted into the pathway. In every other respect this is working appropriately, it's just on deleting the image.

    Any ideas?
      • 23571
      • 223 Posts
      I am having no luck resolving this issue and was just wondering if anyone has seen this error. I have been making the assumption that this is a pathway issue somewhere in Settings, but can't track down the solution.
        • 18373 ☆ A M B ☆
        • 3,141 Posts
        Mark Hamstra Reply #3, 15 years ago
        Did you do anything with the filemanager_* and rb_base_* settings?
          Mark Hamstra • Developer spending his days working on Premium Extras and a MODX Site Dashboard with the ability to remotely upgrade MODX and extras to make the MODX world a little better.

          Tweet me @mark_hamstra, check my infrequent blog at markhamstra.com, my slightly more frequent ramblings at MODX.today or see code at Github.
          • 23571
          • 223 Posts
          Yes, right now am using assets/Users/Images/ on both. Get the same results with rb_base empty.



            • 37197
            • 2 Posts
            I'm having the exact same problem. Did you get this resolved?
              • 23571
              • 223 Posts
              No, never did get it resolved.
                • 37197
                • 2 Posts
                WOW! What a speedy response. We'll just have to keep chipping away...
                  • 15083
                  • 697 Posts
                  Im getting this problem also.
                  Very much looking forward to a resolution smiley
                  I have the same version number. Apache on linux.
                    • 37261 ☆ A M B ☆
                    • 113 Posts
                    Ditto for me. Anyone have a fix for this? I've tried everything I can think of.

                    /home/public_html/specials/assets/images/undefined/filename.jpg
                      • 15083
                      • 697 Posts
                      I believe the problem is not with the delete, but with the update after a delete.
                      When you delete the call to directory.php returns "Access Denied", it should refresh the resource browser and remove the deleted image. Error is thrown when u try and delete the already deleted image!

                      I would imagine the undefined in the url is because the image no longer exists...

                      I plan to look at this over the next week or so, other stuff on the pile first tho smiley
                      I too was hoping someone would get to it first!