We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 36532
    • 8 Posts
    Hello !

    I am new to MODx. I like the fact that you can control what is output on the screen the way I want.

    However, as I'm trying to build a blog, I'm having a problem.

    This is a blog post:
    http://conradk.com/blog/php-security.html

    How can I remove the .html from the clean URL ?

    This is the blog page that is suppose to list the blog posts:
    http://conradk.com/blog/

    Instead it outputs the MODx code. I've made a screenshot so you guys can see what code I used.
    EDIT: added a second screen shot of my chunk code for the blog post. It's basically the one from the blog tutorial without the commenting parts.

    I've installed getResources and it returned no errors.

    I'd be very thankful to those who can help me.

    Best regards,
    CK [ed. note: conradk last edited this post 15 years, 1 month ago.]
      • 36532
      • 8 Posts
      Anyone ?

      Btw, I'm now blocked out of my admin account. Tried to look into phpmyadmin but it doesn't seem like my account is blocked.

      When I enter my password, I get no error message, but I don't get access to the admin interface either xD Tried deleting my cookies. Didn't work.
        • 33968
        • 863 Posts
        How can I remove the .html from the clean URL ?
        In the manager, go to System > Content Types and then remove '.html' from the HTML content type (don't remove the whole content type though).
          • 36532
          • 8 Posts
          Ah, ok thanks ! I tried to remove the whole content type but that didn't work. Hadn't thought about removing just the extension.

          Thanks !