Hello,
I'm moving Revo 2.1.3 to new server. I've done everything as written in documentation (moving files, db, updating config settings and paths, updating workspace table). But I get error 500 on front end and this error on backend:
Strict Standards: strftime() [function.strftime]: It is not safe to rely on the system's timezone settings. Please use the date.timezone setting, the TZ environment variable or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'Europe/Berlin' for 'CEST/2.0/DST' instead in /users/......./core/model/modx/modx.class.php on line 2054
The server is Apache with PHP 5.2.17, MySql 5.0.75
I've deleted all cash folder, but problems remains.
I've run setup, but problem remains.
Please advice me what to do else???
[ed. note: lx last edited this post 15 years, 1 month ago.]
-
MODX Staff
- 10,725 Posts
All 5.2 (and later) PHP configurations should have the date.timezone set. If it is not, contact your host to have it set properly.
Hi opengeek.
the problem is that date.timezone is properly set
-
MODX Staff
- 10,725 Posts
No. The problem is that it is not properly set in the php.ini for your server.
ufff... Found the problem.
I was moving site on the same server but just different hosting accounts. There ware very, very little differences in database names, and the site on the new account was conected to the db from the old account. So after this change everything is OK.
Lucas