On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hej.
    Efter meget søgen og test af de forskellige koder til .htaccess filen kan jeg bare ikke få det til at virke så nu prøver jeg at skrive her.
    Den skriver hele tiden "Internal Server Error".
    Mit modx er installeret i root på serveren.
    Min .htaccess fil ser sådan ud:
    #php_flag zlib.output_compression On
    #php_value zlib.output_compression_level 5
    
    # Rewrite directives here for SEF (Search Engine Friendly) URLs
    
    RewriteEngine on
    
    RewriteBase /
    
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    
    RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA]

    Inde i modx cms står det sådan:
    Use friendly URLs: yes
    Prefix for friendly URLs:
    Suffix for friendly URLs: .html
    Use friendly aliases: yes
    Use friendly alias path: no
    Allow duplicate aliases: no
    Automatically generate alias: yes

    Jeg har undersøgt om siden kører på Apache server og det gør den. Derudover har jeg også undersøgt om Mod_Rewrite modulet er understøttet og det er det også.

    Hvad er det jeg gør galt siden jeg ikke kan få det til at virke?
    Håber der kommer nogle svar nu når der ikke er skrevet nogle tråde i forvejen smiley
    • YES, nu fik jeg det til at virke, det er fordi jeg har kaldt min index fil for index2.php fordi jeg ikke vil sætte siden online mens jeg laver den.
      I .htaccess filen skulle denne linie:
      RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA]

      Rettes til denne:
      RewriteRule ^(.*)$ /index2.php?q=$1 [L,QSA]

      Nå, men for en god ordens skyld vil det da være meget lækkert hvis der var nogen der kunne give lidt lyd fra sig så man kan se der er nogen der kan hjælpe en en anden gang wink
      • Hmm. Prøvde å følge oppsettet ditt men fikk det ikke til å virke.

        min .htaccess fil ser nå slik ut:

        #Options +FollowSymlinks
        RewriteEngine On
        RewriteBase /

        # Rewrite www.domain.com -> domain.com -- used with SEO Strict URLs plugin
        # RewriteCond %{REQUEST_FILENAME} .
        # RewriteCond %{REQUEST_FILENAME} !^example-domain-please-change\.com [NC]
        # RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA,NC]
        #
        # or for the opposite domain.com -> www.domain.com use the following
        # >>> DO NOT USE BOTH THE ABOVE AND BELOW <<<
        #
        #RewriteCond %{HTTP_HOST} .
        #RewriteCond %{HTTP_HOST} !^www\.example-domain-please-change\.com [NC]
        #RewriteRule (.*) http://www.example-domain-please-change.com/$1 [R=301,L]

        # Rewrite secure requests properly to prevent SSL cert warnings, e.g. prevent
        # https://www.domain.com when your cert only allows https://secure.domain.com
        #RewriteCond %{SERVER_PORT} !^443
        #RewriteRule (.*) https://example-domain-please-change.com.com/$1 [R=301,L]



        # The Friendly URLs part
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]



        # Make sure .htc files are served with the proper MIME type, which is critical # for XP SP2. Un-comment if your host allows htaccess MIME type overrides.

        #AddType text/x-component .htc osv ...

        Oppsettet i modx er identisk med eksempel du peker på.

        Siten ligger i et egen mappe under root nivå, og .htaccess filen ligger på toppnivå i denne mappen. Web-serveren er en mac.

        Når jeg klikker på linkene får jeg "File not found!" fra apache serveren...

        Ser noen feilen?


        • Kunne heller ikke få userfriendly urls til at virke, vil prøve med dine metode når jeg kommet så langt.