We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 21644
    • 6 Posts
    Добрый день,
    После установки MODx 1.0.4 на бесплатный хостинг и импорта базы с локалхоста появляется ошибка
    (перенос делал согласно инструкции)

    PHP error debug
    Error: Missing argument 1 for AjaxSearch::run(), called in /home/vhosts/www.мойсайт.com/manager/includes/document.parser.class.inc.php(770) : eval()’d code on line 399 and defined
    Error type/ Nr.: Warning - 2
    File: /home/vhosts/www.мойсайт.com/assets/snippets/ajaxSearch/classes/ajaxSearch.class.inc.php
    Line: 64
    Line 64 source: function run($tstart, $dcfg, $cfg = null) {

    В чем может быть дело?

    Заранее спасибо,
    NLObP
      • 31136
      • 72 Posts
      Убедитесь, что AjaxSearch работает у вас на предыдущем хостинге (локальном компьютере). У меня возникла абсолютно такая же проблема. Причина - версия кода сниппета в админке была ниже, чем версия AjaxSearch в папке сниппетов. Решение: открываем assets\snippets\ajaxSearch\snippet.ajaxSearch.txt и записываем этот текст через админку в сниппет AjaxSearch.