On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • На локальной машине установил Apache 2.2.14 + Php 5.2.11 + MySQL 4.1 + ModX 1.0.1. При попытке проверить доступность базы данных пользователя тишина, запрос не отправляется.
    Из консоли захожу на сервер MySQL -- выполняется безоговорочно.
    Смотрю в логи Апача -- 127.0.0.1 - - [01/Nov/2009:20:49:12 +0200] "POST /install/connection.collation.php HTTP/1.1" 500 -
    Багзилла молчит.

    На сервере только МодХ

    В связи с этим...

    ВОПРОС:
    Почему не выполняется запрос?

    • Сегодня тоже столкнулся с такой проблемой (правда в лог аппсерва не лазил). Долго думал, выход оказался до невозможуности ппцовым... нужно было при установке аппсерва прописывать в начальных настройках не localhost а 127.0.0.1 и входить так... (странное как-то, хоть я и не особо в этом соображаю).
      У меня лично такая фигня получилась на аппсерв 2.6.0, там php и mysql последние, на 2.4.8 - норм, щас на версях повыше пробовать буду.
      • может это из-за того что в файле hosts винды не прописано что localhost это 127.0.0.1 ?
        • Та же фигня но при установке на удаленный сервер. не пойму в чем дело. Database host у хостеров тож локалхост. Жму проверить и тишина. Причем версии 0.9 ставились на ура. huh
          • Пытаюсь установить на сервер не на локалку, нажимаю Нажмите здесь для проверки соединения с вашим сервером базы данных и получения сопоставления кодировки то вообще ничего не происходит то грузит непонятно что, а толку 0 даже ошибки не вылазиют никакие.
            в чем проблема может быть? версия modx-1.0.5
            а ещё в дистрибутиве файл ht.access он разве не такой должен быть .htaccess?
            • Quote from: yuginok at May 27, 2011, 09:25 AM

              Пытаюсь установить на сервер не на локалку
              А зачем тогда в эту тему пишете?
              См. http://modxcms.com/forums/index.php/topic,64760.msg366337.html#msg366337
                Создание сайтов на MODx, поддержка сайтов, поисковая оптимизация, программирование, копирайтинг
                Статьи о MODx, регулярно новые публикации
              • Аналогично, ставлю на удалённый сервер evo 1.0.5 и при проверке соединения с бд тишина. Через PhpMyAdmin захожу нормально, конект есть.

                Как вижу проблема не диковинная, но ни одного ответа нет. Жаль...

                З.Ы. На этом сервере у меня стояла revo 2.0.8, но после апдейта многие апи ушли в прошлое, а переписывать всё под новые стандарты влом, решил откатится до evo. Локально всё работает на ура.
                • Quote from: 0dmin at Jun 03, 2011, 06:57 AM

                  Как вижу проблема не диковинная, но ни одного ответа нет. Жаль...
                  А читать ответы не пробовали? И почему об установке на удаленный сервер пишите в теме о локальной установке, когда есть отдельная тема, и даже ссылка на нее есть в этой теме. Но, конечно, если читать не умеете, то «но ни одного ответа нет».
                    Создание сайтов на MODx, поддержка сайтов, поисковая оптимизация, программирование, копирайтинг
                    Статьи о MODx, регулярно новые публикации
                  • Аналогичная проблема, версия Evolution-1.4.0, постоянно удаляю и распаковываю заново из одного и того же исходника. То ставиться - то не ставиться.. понять логику такого поведения сложно, но она определённо есть...

                    Может сам найду причину, может кто поможет и первей напишет в топик...
                    • Quote from: donland at Feb 21, 2018, 10:38 PM
                      Аналогичная проблема, версия Evolution-1.4.0, постоянно удаляю и распаковываю заново из одного и того же исходника. То ставиться - то не ставиться.. понять логику такого поведения сложно, но она определённо есть...

                      Может сам найду причину, может кто поможет и первей напишет в топик...

                      попробовал зайти через браузер в приватном режиме, и всё заработало без перезагрузок сервера и т.п.

                      Подозреваю что-то с кэш-браузера (Cookie) или сессиями. Но простое удаление cookie в браузере для домена сайта не помогает.