New Community Forums are coming. Watch this space for news.
Subscribe: RSS
  • Беда с дружественными URL.

    Alias в БД сохраняется! Все пути в ссылках движком ModX строятся как надо! Т.е. mydomen/folder/ - но сам сервак их не отрабатывает. Я грешу на .htaccess

    По-умолчанию он почему-то был обозван как ht.access (в папках / и /manager) - переименовал на .htaccess, но в сам файл не лез, так что он родной 0.9.6.1

    404 - прописал на отдельную страницу с id отличным от главной. UTF-8 и алиасы корректные латиницей, вид URL - все пучком. Документы со статусом ОПУБЛИКОВАНО. Но вы дается стандартное Denwer’овское сообщение "Not Found. The requested URL /folder/ was not found on this server."

    Как быть?

    Система: Windows, Denwer, ModX 0.9.6.1

    Прилагаю содержимое .htaccess (комменты порезал):

    RewriteEngine On
    RewriteBase /
    
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
    
    • в файле конфига апача httpd.conf разкомментировать строку
      LoadModule rewrite_module modules/mod_rewrite.so
      • Спасибо за подсказку. Она натолкнула меня на мысль написать для ModX конструкцию, которую использует WordPress.

        <IfModule mod_rewrite.c>
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
        </IfModule>


        Все работает без правки файла конфигурации Апача. Пользуйтесь.

        p.s. Странно, что команда ModX не создала того же самого. Данные грабли носят тотальный характер.
        • иногда бывает так что мод_рерайт включен но все равно не работает...

          RewriteEngine on
          Options +FollowSymlinks (важная строка в этом случае)
          RewriteBase /
          RewriteCond %{REQUEST_FILENAME} !-f
          RewriteCond %{REQUEST_FILENAME} !-d
          RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

          p.s. (от модератора) первое предупреждение на счет кодировки. подробности.
          • Проблема с Friendly URLs

            Что не делаю.. все равно получаю ощибку 404. Даже если использовать SEO (Google) Friendly URLs или Friendly urls без mod_rewrite

            В настройках апач mod_rewrite вкл. И вроде как работает так как переадресация типа domain.com -> www.domain.com выполняется
            Options +FollowSymlinks
            RewriteEngine On
            RewriteBase /
            RewriteCond %{HTTP_HOST} !^www\.mydomain.spb\.ru [nc]
            RewriteRule (.*) http://www.mydomain.spb.ru/$1 [R=301,L]
            
            
            # The Friendly URLs part
            RewriteCond %{REQUEST_FILENAME} !-f
            RewriteCond %{REQUEST_FILENAME} !-d
            RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]


            Где и в чем может быть ошибка huh
            • Проверь в конфиге апаче эту директиву
              <Directory />
                    Options FollowSymLinks
                    AllowOverride all
              </Directory>
              • Смешно, наверное - в пути два слэша: site.ru//page.php Если быстро найду - сотру темку, но ищу уже минут 20:)

                P.S. Нашел:) Последовал совету тут и прописал в шаблоне siteUrl и baseUrl рядом, а сайт-то в корне... вместо бэйс урл мод-икс ставит слэш...
                • Переделал все вышесказаное и всеравно редиректят УРЛ ЧПУ на главную Денвера - подскажите пож как можно решить эту проблему?

                  П.С.
                  В файле апача строка раскоментирована LoadModule rewrite_module modules/mod_rewrite.so

                  сделал в .htaccesse так:
                  RewriteEngine On
                  Options +FollowSymlinks
                  RewriteBase /
                  RewriteCond %{REQUEST_FILENAME} !-f
                  RewriteCond %{REQUEST_FILENAME} !-d
                  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]


                  так же пробовал так:
                  <IfModule mod_rewrite.c>
                  RewriteCond %{REQUEST_FILENAME} !-f
                  RewriteCond %{REQUEST_FILENAME} !-d
                  RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
                  </IfModule>
                  • Quote from: Gut at Dec 19, 2007, 11:33 AM
                    Спасибо за подсказку. Она натолкнула меня на мысль написать для ModX конструкцию, которую использует WordPress.

                    <ifmodule mod_rewrite.c="">
                    RewriteCond %{REQUEST_FILENAME} !-f
                    RewriteCond %{REQUEST_FILENAME} !-d
                    RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
                    </ifmodule>


                    Все работает без правки файла конфигурации Апача. Пользуйтесь.

                    p.s. Странно, что команда ModX не создала того же самого. Данные грабли носят тотальный характер.
                    А где писать эту конструкцию?
                    • Здравствуйте!
                      Пытаюсь перенести сайт на ModX Evo 1.0.10-d5.3
                      для начала пытаюсь запустить его у себя
                      Apache/2.4.7 (Ubuntu)
                      PHP Version 5.5.9-1ubuntu4.5
                      Mysql 5.5.40

                      Экспортировал базу данных, ввел аккаунт-пароль mysql пользователя в config
                      Админка работает. очистил кэш.

                      Работает первая только страница. Включены friendly URL, по ним выдаётся 404, если отключить по запросу index.php?q=... выдаёт redirect loop

                      .htacess в корне

                      RewriteEngine On
                      RewriteBase /

                      не могли бы вы подсказать, в чём загвоздка.
                      Спасибо! )