On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • http://modxcms.com/beta.html

    こちらで配布が始まったMODx 0.9.6 RC3対応の日本語ファイルです。
    まだまだ英語が残ってますが。。
    興味のある方はご利用ください。また、細かい点について指摘をいただけると嬉しいです。

    http://modxcms.com/forums/index.php?action=dlattach;topic=14036.0;attach=5011
    こちらからダウンロード。

    ※ RC3で追加されたエントリーもマージ済み

    「言語ファイルのエントリ数が異なります。」と表示されるなどの問題があればご一報ください。
    • 同梱のDittoのlangファイルのバージョンが1.x系準拠になってました。

      http://modxcms.com/forums/index.php/topic,14430.msg94292.html
      こちらで、とりあえず最新のものをゲットしてください。
      • 最新のlangファイル(管理画面用)ではsetlocaleの記述が必須となってるようですが、
        ココをja_JP.UTF-8とかにするとマズいサーバ多いですよね?
        ja_JPかjaのどっちかがいいのではと迷い中です。

        ※19時30分追記
        っていうか、対応してないレンサバが多いはずなので、MODxコアが自前で持ってほしい気もします。
        langファイルで指定されたロケールが存在しない場合、MODx自前のテーブルを読みに行く形。

        ロケールに対応できるとありがたいです。02-05-07などの日付形式を2007/05/02などとできるし
        曜日の表現も月火水木を利用できるし。。
        • http://modxcms.com/forums/index.php?action=dlattach;topic=14036.0;attach=4993

          新しいものをアップしました。あと、Dittoのlangが1.x系だったため2.x系に差し替えました。
          chobiさんが作ったファイルをほぼそのまま採用です。ありがとうございます。 laugh
          (ただしUTF-8のみ)
          • 言語ファイルありがとうございます。
            一部問題がありましたので、ご報告します。

            http://modxcms.com/forums/index.php?action=dlattach;topic=14036.0;attach=4993

            上記URLからダウンロードした言語ファイルのうち、
            modules\quick_edit\lang\japanese-utf8.inc.php を
            アップロードしますと、096rc3で、管理画面からプレビューができなくなります。

            具体的に書きますと。

            1.まず、本家から、096rc3をダウンロードし新規インストール
              この時点では、とくに問題なく、管理画面の サイト> プレビューを実行するとホームページが表示されます。
            2.上記URLより、言語パックをダウンロード、解凍し、該当ディレクトリに上書きコピー
              管理画面 サイト>プレビューを実行するとウィンドウは立ち上がりますが、画面には何も表示されません。

            何がひっかかっているのか試したところ、「modules\quick_edit\lang\japanese-utf8.inc.php」を
            アップロードした時点で、問題が起きました。

            また、問題が起きた後、
            本家よりダウンロードしたファイルに含まれる、「modules\quick_edit\lang\japanese-utf8.inc.php」を
            上書きアップロードしたところ、正常に動作するようになりました。

            検証よろしくお願い致します。
            • わかりました。

              modules\quick_edit\lang\japanese-utf8.inc.php の

              setlocale (LC_ALL, ’ja_JP’);

              の後がコメントになってない(/* ヌケ)のが原因のようです。
              • http://modxcms.com/forums/index.php?action=dlattach;topic=14036.0;attach=5011
                修正しました。そもそもこのエントリーを追加した場所が間違ってました。
                と言いつつ、今からRC3を試すところです。
                • いよいよインストーラの国際化に着手するようです。langファイルの配布が始まりました。
                  ごく一部のみをテストがてら翻訳しましたが、どなたか残りの翻訳をお手伝いいただけると助かります。
                  とりあえずココに貼り付けておきます。
                  ってことは、0.9.6のリリースはまだ遅れそうですね。