今まで動いていた専用SSLを入れているサブドメインでも modx を再インストールしたところ同じようなエラーが表示されるようになり動かなくなりました。
原因は何かというとたぶん、2月のはじめに何度もサーバーが停止していたのですがそのときに PHP5 への入替えが行われていたようです。Joes の発表では不正なアクセスにより不安定な状況に ・・・ と発表されており虚偽の内容に近いようです。当方の利用している server19 ですが
Joes の PHPバージョンアップ予定日のページではすでに server19 は昨年 2008年10月に PHP5 への移行準備が完了していることになっているのですがその場合には標準の PHPバージョンが 4.4.7 から 4.4.9 になるはずでした。
http://www.joeswebhosting.net/php_ver_up.html
実際に 4.4.9 になったのは2月はじめの不安定だった時から以降です。したがって Joes は事実をユーザーに伝えていない状況です。同時に mod_phpから、fastcgiへの移行も行われています。
その結果 preg_match_all() でエラーが発生する原因となっているようです。同時に不可解な別の問題も発生しています。 modx のページにアクセスするたびに modx ルートにおかしな core ダンプファイルが増えていきます。
core.11095
core.11096
core.11097
core.11098
・
・
・
・
core.15233
core.15282
core.17162
core.28839
core.29739
core.31224
core.3633
それぞれ 7MB 以上あってアクセスするたびに新しく作成され増えていきます。Joes を使っている人がこのフォーラムでもおいでましたら情報交換できないものかと思っております。
またこの現象はすでに稼働中の Joomla、osCommarce などでは発生しません。以前にテストで入れていた modx9.2.1 でもこのようなことはありません。
Joes で一番悩んでいることは PHP5 への完全移行までに拡張子を PHP5に変更する以外にテストする手段がないことで、これはとくにCMSでは致命的です。そのため今年の6月にはさくらインターネットなどへの移転も考えている次第です。
Joes はメールで問い合わせてもなかなか返事がもらえない上、良心的な回答がもらえるとも思えません。とくに modx については個々の問題といわれればそれまでです。
以上の理由から現状では modx とくに sslSwitcher で専用SSL、および共有SSLのテストはできなくなりましたことをお詫び申し上げます。そのため専用SSLの代替で
https://example.sakura.ne.jp/ 形式が利用できるようになった時点での検証になると思います。何か解決につながる情報などありましたらこちらまで、またはプライベートメッセージにてお待ちいたします。
よろしくお願いいたします。 :’(