We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33356
    • 7 Posts
    ログインしようとしたら、『Captcha is not configured prorerly.』と表示されてしまい、管理画面にログインできなくなりました :’(

    以下の状況で起こった現象です。

    1:http://www.aaaaaaaaa.com/modx/にインストールして作成してました。(ログイン時のキャプチャコードON)
    2:CORESERVER(XREA)の同じ共有サーバー内にある別のドメイン(http://www.bbbbbbbbbb.com/)に移管作業を行いました。
    ※データベースはそのまま同じものを使用しています。
    3:古いサーバーにある時点で、MODx設定のリソースパスなどは、新しいサイトのものにし、キャッシュをクリアしてFTPでダウンロードしました。
    4:ダウンロードしたファイル群を新しいサイトのディレクトリに移し、.htaccessをのフレンドリーURL用の部分を書きなおしました。
    5:assets内のフォルダ&ファイルのパーミッションを設定しました。
    6:通常通り、サイトは表示されますが、managerへのログイン時にキャプチャコードが表示されず、青字のリンク文章のみ表示されていました。
    ※リンク文章引用『画像で表示されるセキュリティコードを入力してください。セキュリティコードが読めない場合は画像をクリックすると画像は再生成されます。もしくはサイト管理者に連絡をお願います。』
    7:siteCache.idx.phpの設定でキャプチャコードを使用しないように”0”にしました。
    8:キャプチャコードはなくなりましたが、IDとPASSを入力しても『Captcha is not configured prorerly.』と表示されてしまいログインできません。
    9:phpMyAdmin上で、ログイン3回失敗した場合の対処法を参考に行ってみましたがだめでした。
    10:パスワードを忘れた時のためのメール送信で送られてきたURLでも、8の項目と同じエラーが表示されます。

    これ以上どのように対処していいか分かりませんので応援お願いします。

    環境は、

    サーバー:s55.coreserver.jp
    PHP:5.2.5
    MySQL: 5.1.22
    MODx:0.9.6.1

    になります。
      • 19033
      • 892 Posts
      こんにちは。

      phpMyAdmin などでデータベースに接続して、
      system_settings の use_captcha が1 になっていたら、
      0にしてみてください。
        • 33356
        • 7 Posts
        Quote from: MEGU at Mar 27, 2008, 10:15 AM

        phpMyAdmin などでデータベースに接続して、
        system_settings の use_captcha が1 になっていたら、
        0にしてみてください。

        上記には書いていませんでしたが、データベース側でも確認していました。
        値は”0”になっています。
        ちなみに不可解なことに、IEで見るとレイアウトが崩れてました。
        また、IEの場合だけ、一部のリンクが破損していました。
        FXやSafariで見ても問題はありません。

        データベースの破損が原因でしょうか huh
          • 36592
          • 970 Posts
          MODxのソース内でそのエラーメッセージを吐き出しているところを探してみましたが、
          manager/processors/login.processor.php に以下の部分が見つかりました。
          if($use_captcha==1) {
          	if (!isset ($_SESSION['veriword'])) {
          		jsAlert('Captcha is not configured properly.');
          		return;
          	}
          	elseif ($_SESSION['veriword'] != $captcha_code) {
                  jsAlert($e->errors[905]);
                  $newloginerror = 1;
              }
          }
          

          2つのif文がともにTrue、すなわち「$use_captcha==1」かつ「!isset ($_SESSION[’veriword’])」となっているのかな~
          どこかにまだ「$use_captcha=1」という部分が残っているのでは?
          やはりキャッシュが疑わしいと思いますが...
          キャッシュを改めて全てクリアして、assets/cacheの下の「siteCache.idx.php」をMODxのオリジナルファイルからコピーしてみては?
          ※バックアップは適切に残して下さいね~ 何があっても責任取れません。
            • 33356
            • 7 Posts
            ご回答ありがとうございます。
            始め点の減少で困惑しておりますが、指摘いただいた部分も含め対処してみます。

            解決方法がわかりましたら、今後の方のためまた残しておきます。