We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 20871
    • 3 Posts
    こんにちは。初めて書き込みします。
    MODxでいくつかサイトを立てているのですが、どうしても分からない問題にぶち当たりましたのでご教授下さい。

    pieXで、WORDPRESSのフィードを読み込ませ、新着記事表示をさせているページがあるのですが、
    最初の数分を過ぎると「no item」表示になってしまい、全くフィードを読んでくれません。
    念のため他のブログサイトのフィードを読ませて実験させたんですが、結果が同じでした。
    (一応キャッシュをいじくりまわしてみたんですが、あまり状況は変わらず--;
    そもそも、キャッシュはデフォルト設定状態でもちゃんと常時表示されていたので、おかしいなと思ってます)
    pieXを使っていてこういう現象が起きた事がなかったので、どなたか対処法や解決方法をご教授願えませんでしょうか。
    初心者っぽい質問で申し訳ないのですが、何卒よろしくお願いします!

    ちなみに、運用しているのは↓のサイトです。念のためスニペットコールも記載させていただきます。
    http://45cho.sakura.ne.jp/45cho

    [!pieX? &url=`{(site_url)}news/feed` &max=`5` &header=`piex_header` &item=`piex_item`!]

    テンプレの方はMEGUさんのサイトでやられているようなもの(ヘッダーはulタグのみ、アイテム部分も大した事はしてません)なので、特段問題ないかと思います。
      • 33488
      • 429 Posts
      こんにちは、
      えーと、最初は正しく表示されるということであれば、次の取得時になんらかのエラーが発生しているのかも知れません。
      noitemのTPLに[+feed_url+]と[+error+]を埋め込んでみてもらえますでしょうか?
      多分、取得のエラーであれば[+error+]がsimplepieのエラーメッセージに置き換わるんですが・・・。
      simplepieのバージョンはなんでしょうか? もしかすると、最新版だと動かないかも・・・。

        • 20871
        • 3 Posts
        Zeroさん、早速の反応ありがとうございます。

        ちょっとこちらの反応が鈍かったんですが(すいません)、
        とりあえずnoitem時のテンプレートをご指示通りにしてみました。
        表示されたのはとっているフィードのURLと

        A feed could not be found at http://45cho.sakura.ne.jp/45cho/news/feed

        でした。

        でもこのアドレスのフィード、存在してるんですよね。。。
        症状として、フィードの配信元であるWordpressを更新すると一瞬だけ正しい表示になりますが、
        またこれに戻ってしまいます。。。
          • 33488
          • 429 Posts
          なんででしょうねぇ・・
          ちょっと、そのフィードURLを使わせて頂いてテストサイトで動かしてみたんですが問題なく表示されちゃったり・・・。
          ドキュメントそのものは、キャッシュ可でpieXは[!のキャッシュしない呼び出しで行っています。
          ちなみに、こちらで動かしています。

          もしかすると、simplepieのキャッシュ周り huh かも知れません。
          スニペットのプロパティでCache_enableとなっている箇所があるので、これをtrueからfalseにしてもらえますか?
          あと、Simplepieのバージョンは1.1だとテストしていないのでそれかも知れません。
          noitemのテンプレートを利用するのは、実際にはsimplepie側からエラーで返ってきてる場合に使われますので、SImplepie側でなんらかのエラーと判定されてしまっているということになるんですが、んーーー、意外と謎な・・・

            • 20871
            • 3 Posts
            早速のお返事ありがとうございます!

            プロパティーの「cache enable」をfalseにしたところ、
            今度は常時取得がしっかりと出来るようになりました。
            一応10分置きとかに動作確認してみましたが、難なく動いているようです。
            ご指摘通りcacheが原因のようですね。
            pieXは他のサイトでも使用させていただいておりまして、大変重宝してますので
            これで元のように使える事になり安心いたしました。
            お手数おかけしてまことにありがとうございました。感謝いたします!
              • 33488
              • 429 Posts
              いえいえ、原因がわかってよかったです。
              あと、simplepieも1.1に上がっていますので、一応動いているみたいです。

              しかし、キャッシュがおかしいのはなぜだろう?? シリアライズでエラーになってるかも。
              とりあえず、OFFで運用をお願いします  :’(