こんにちは。
9.5をインストールした環境に、9.2.2で動いていたデータベースを流し込んだところ、
Site Template Variables Templates Link Table
のフィールド数が一つ多い、という現象が起きました。
9.5環境では、データベースに存在しないフィールドを呼び出そうとするからか、
DittoやAjax searchなどのスニペットを使用しているページはパース・エラーが出、
また、管理画面のドキュメント編集ページの中のテンプレート変数をリストすると思しき部分にも
tr.rankがフィールドリストの中にないのでエラー
といわれてしまいます。
9.5で使えるデータベースの情報について、心当たりのかた教えていただきたいのですが…
0.9.5のInstallディレクトリのsetup.sqlが構造定義のSQL文が入っていますよ
アップグレード時だと、既に存在していればそのままにしているので、多いカラムをつけちゃえばいいような気がしますが、
そのカラムがなんなのかが問題かも・・。
スニペット系は、改造していなければ・・問題はないような気がしますが、やはりSQLでエラーになった部分が入ってないせいとかが関係しているのかも知れませんねぇ。
ZeRoさん
お答え有難うございます。
ただのアップグレード作業だと既存DBはそのまま、ということですが、
そのままの書き換えがなされない状態の既存DBが使えないということは、
9.5が要求するDBの情報は以前のバージョンと互換性がないということと取ってもよいのでしょうか。
多いカラムをつけてしまえばいい…ということでは少々インフォメーションが少なく、
折角お答えいただいたのですが、9.5を使うのは難しい状態になってきました。
9.2に戻す作業をしなくてはいけないのですが、
新しいサーバーに移すと、サイト表示に使うファイルが見つからないといわれる有様で、現在かなり困っています。
他トピックを立ててまた質問したいと思います…
有難うございました。
調べてみました。
9.2.2から正しく9.5へアップグレードすると、9.2にはなかったカラムが自動的に追加されます。
9.5にインストール後に9.2のDBをリストアさせることで9.5のDBのスキーマと合わないのが原因だと思います。
9.2のDBのまま、9.5にアップグレードすれば正常にいけるかと思いますよ。
今回のDBスキーマの変更は、スニペットやTV、プラグインなどにカテゴリが導入されたのでそのカテゴリの情報がカラムとして追加されたり、ほかにも9.5特有の設定情報が追加になっています。
追加になったカラムは、元々9.2にはなかった情報なのでカラムを追加しただけの空の状態であっても、問題はないはずです。(実際にアップグレードをいくつか試しましたが、今のところ問題はないです)
上記の例だと、カテゴリはなかったのですから9.2にアップグレード時の既存のスニペット類はuncategorizedに振り分けされます。(されました)
とはいえ、ちょっと怖いなという意識が働くのはありますが・・・。
別マシンで同じような手順を実験できるのがいいんですけど・・。