On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • .htaccessにRewrite関連のタグを入れるとMODx自体が表示されなくなってしまいます。
    php_flagの部分も同様のエラーがあったのですが、こちらはphp.iniで設定することにより解決しました。
    Rewrite関連のタグが使えるようになる方法はありますでしょうか。
    使用しているサーバーはKDDIです。
    • 上記の説明ですと状況や条件が分からず、関係者の方も返答に困ると思いますので、もう少し詳しく書けますか?

       ・何をしたいのか/どのような結果を望んでいるのか(Rewrite文を書く目的)
       ・MODx(管理画面)内でどのような操作を行ったか
       ・.htaccessに記述した制御文は?
       ・yossi440さんのスキルレベル(CMSの使用経験、Apache/PHP/MySQLの知識など)

      仮にフレンドリーURLが目的でしたら、インストールフォルダの"ht.access"を".htaccess"に変名されましたでしょうか?.htaccessやphp.iniによるウェブサーバやPHPの制御方法はサーバによって違いがありますので、当該ホスティング会社に問い合わせるのが一番なのですがサポート対象外と言われてしまうかもしれません。KDDIには”CMSインストーラー”があるようですがその中にMODxはないですね。でも、WordPressを仮インストールして.htaccessやphp.iniの設定を見ることで解決の糸口がつかめるかもしれません。
      • アドバイスありがとうございます。
        MODxは何度もインストールしており、サーバーもいろいろ使っておりましたが、Apache/PHP/MySQLは詳しくありません。
        フレンドリーURLが使いたいのですが、.htaccessの中に
        RewriteEngine On
        RewriteBase /
        RewriteCond %{HTTP_USER_AGENT} ^.*internal\ dummy\ connection.*$ [NC]
        RewriteRule .* - [F,L]
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
        を記載すると画面が出てこなくなってしまいます。
        php.iniは.htaccess中に
        AddHandler x-httpd-php524 .php
        を記述してルートディレクトリにphp.iniを置くことが出来るのでphp_flagの部分はこちらで制御しています。
        KDDIに問い合わせたのですが、.htaccessはサポート外でした。
        WordPressを仮インストールして試してみるという案もありがとうございます。
        • いろいろとアドバイスありがとうございました。
          Let’s enjoy MODxの掲示板でアドバイスしていただいたもので解決しました。
          http://blog.knym.net/items/2509/
          に書かれていたように.htaccessに
          Options +FollowSymLinks
          を記述したらきちんと表示されるようになり、かつフレンドリーURLも機能するようになりました。
          感謝!感謝!です。
          • はからずも"WordPress"というキーワードがお役に立ったようでなによりです(情報を公開してくださってる方にも感謝)。 ^^
            CPIさんもそれっぽいようですが、若干上級者向けのサーバみたいですね。さくらの「Option指定ダメよ~」は承知してましたが、「FollowSymLinksがないとダメ」ってケースもあるんですね・・・システムの柔軟性が返ってアダになってる感じでしょうか。。。

            >yamaさん
            Evo期待の次期リリース・・・Options +FollowSymLinksの件きっちり広報せんと、、、ですね。
            • FollowSymLinksがデフォルトで無効になってるケースですね。グローバル設定のフレンドリーURL設定画面に注意書きをしておきました。