On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • いつもお世話になっています。去年MODxを導入して以来、ページの更新が楽になり、おかげさまでアクセス数も格段に増えました。アドバイスをくれた方々、ありがとうございます。 laugh

    質問があるのですがよろしくお願いします。

    今は0.9.6.1を使っています。0.9.6.3が出ているようですがそのことについてです。

    1)最新版のほうが、使いやすいのですか?(更新が楽?)

    2)よくセキュリティーの話が出ますが、最新版のほうがセキュリティーに強いのでしょうか?(今まで使っていて、特に支障はありませんでした)

    3)インストールする場合、どのファイル(フォルダ)を残して、どのファイル(フォルダ)をインストールすればよいのでしょうか?
    assets(フォルダ)
    ht.access(ファイル)
    index-ajax.php(ファイル)
    index.php(ファイル)
    install(フォルダ)
    manager(フォルダ)
    sample-robots.txt(ファイル)

    4)これからも新しいバージョンが出されると思いますが、その都度アップグレードしたほうがよいのでしょうか?(なんとなく新しいほうがよさそう?)

    以上なのですがよろしくお願いします。

    “MODx”本当に素晴らしいです shocked

    • clovergardenさんはじめまして。

      アップグレードは、皆さん様々な考えを持っています。以下はあくまで個人的な見解や手法としてお聞きください。

      Quote from: clovergarden at May 31, 2009, 11:55 PM

      1)最新版のほうが、使いやすいのですか?(更新が楽?)
      不具合の修正と共に、仕様変更なども盛り込まれますので「最新版のほうが使いやすい」とは限りません。通常旧バージョンとの互換性を考慮して変更がなされますが、場合によっては自前で作りこんだプログラムが動作しなくなる場合もありえます。また、変更されたことが使用者にとっては改悪に見えることもあります(以前はこうなってたのに・・・みたいな)。更新の手間やリスクに変わりはないと思います。

      Quote from: clovergarden at May 31, 2009, 11:55 PM

      2)よくセキュリティーの話が出ますが、最新版のほうがセキュリティーに強いのでしょうか?(今まで使っていて、特に支障はありませんでした)
      日頃セキュリティパッチを適用していないのでしたらバージョンアップすることをお勧めします。ただ、セキュリティに関しては、バージョンをあげるかどうかという判断とは別に、日頃からセキィリティリリースに目を通す習慣を付けて、特に重度な問題と対処方法がリリースされたときはなるべく早く適用することが必要不可欠です。

      Quote from: clovergarden at May 31, 2009, 11:55 PM

      3)インストールする場合、どのファイル(フォルダ)を残して、どのファイル(フォルダ)をインストールすればよいのでしょうか?
      assets(フォルダ)
      ht.access(ファイル)
      index-ajax.php(ファイル)
      index.php(ファイル)
      install(フォルダ)
      manager(フォルダ)
      sample-robots.txt(ファイル)
      細かいファイルの説明はありませんが、下のサイトが参考になると思います。
      http://wiki.modx.jp/index.php/MODx%E3%81%AE%E3%83%90%E3%83%BC%E3%82%B8%E3%83%A7%E3%83%B3%E3%82%A2%E3%83%83%E3%83%97%E3%81%AB%E3%81%A4%E3%81%84%E3%81%A6

      Quote from: clovergarden at May 31, 2009, 11:55 PM

      4)これからも新しいバージョンが出されると思いますが、その都度アップグレードしたほうがよいのでしょうか?(なんとなく新しいほうがよさそう?)
      アップグレードは、結構手間が掛かりますので判断が難しいですよね。新しければよいというものではなく、人によっては「0.9.5/0.9.6.1/0.9.6.2の方が良かった」と思う人もいるはずです。セキュリティ関連も、既存のパッチが適用されて既存のセキュリティホールが埋められても、追加された機能に新しいセキュリティホールが見つかることもありますので、一概にアップグレードがよいとは言えません。

      とはいえ、セキュリティという言葉の意味やリスクは分かるものの、日頃のセキュリティフィックスの適用方法が分からない方や、技術的な細かい事がしっかり判断できない方(初心者の方など)は、ここぞと思うタイミングでリリース物を信じてアップグレードするしかないのが実情だと思います。

      アップグレードの際に一番気をつけることは、いきなりご自分のサイトをアップグレードしないことです。手間は掛かりますが、サイトのコピーを作り、そちらで十分にテストして問題がないことを確認してから本チャン環境に適用することをお勧めします。コピーはできれば同一環境(サーバ)上に構築すべきですが、ディスク資源が足りなかったりサブフォルダやサブドメインへの設置方法が分からない場合は、xamppを使ってローカルPC上に構築する手もあります。「テスト環境を持っておくこと」は、modxのバージョンアップのみならず、何か新しい部品を試したりする時にも大変重宝しますので、もしこれらのテスト環境を構築してなければ、これをよい機会と考えてチャレンジしてみてはいかがでしょう。
      • sama55さん、ため息が出るほどの完璧なアドバイスありがとうございます。 shocked

        私が疑問に思っていることがすべて解決されました。

        今のバージョンに特に不便を感じないので、時々セキィリティリリースに目を通し対応していきたいと思います。アップグレードするのもかなり手間がかかりそうですし・・・ sad

        xamppを使い方を少し勉強しようと思います。すすめてくださりありがとうございます。

        これからもMODxを使って、いいサイト作りをしていきたいと思います。

        sama55さん本当にありがとうございました。 laugh