On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • :’( とりあえず自己紹介はこの問題がかいけつしてからにしたいと思いますのでよろしくお願いします。

    0.9.6.3RC2 から 0.9.6.3へのアップグレード後 FCKEditor リソースブラウザに画像の一覧が表示されなくなりました。
    もちろん全角の画像ファイル名は使用しておりません。
    また画像のアップロード、フォルダの作成もエラーになります。

    レンタルサーバーはサクラのスタンダードおよび CORESERVER とも同じ状況です。
    新規インストールでは問題なく画像が表示されます(CORESERVERのみ確認)

    0.9.6.1sp2 から 0.9.6.3RC2 までと同じ方法で install からアップグレードを選択していますがいままでこのような状況になったことはありません。今回はなにか特別な注意事項とかありますでしょうか。新しいバージョンのファイルはすべて上書きで FTP送信 しています。

    たとえば「データベースのバックアップを取っておいて新規インストールをしその後データベースをインポートする」といったような方法が確実でしょうか。データベーステーブルの構造が変わったことが原因であればこの方法も取れませんが?

    以上お分かりの方おいでましたらよろしくお願いいたします。
    • はじめまして。

      もう解決されたかもしれませんが、私も同じ状態になり対処しました。
      ベースパスが補完されなくなったことが原因のようです。
      同じ原因でない可能性もありますが、まずは以下のことをご確認ください。

      1.グローバル設定

       ・「ツール」→「グローバル設定」→「インターフェースとその他の機能」
       ・画面中ほどの「リソースパス:」と「リソースURL:」を確認し、"assets/"になっていればアウト
       ・リソースパスにはassetsフォルダまでのサーバ上の物理パスをセット
       ・リソースURLにはassetsフォルダまでのURLをセット
        例 : リソースパス → /home(usr)/hogehoge/www(public_html)/assets/
            リソースURL → http://www.hogehoge.com/assets/

      2.ユーザごとの設定

       ・「ユーザー」→「ユーザー管理」→「インターフェースとその他の機能」と進みます
       ・各ユーザを編集開始→詳細設定タブを開く
       ・画面中ほどの「リソースパス:」と「リソースURL:」を上記と同様に確認&修正

      実はこの部分前からおかしいと思ってたのですが、開発サイドで気がついて直したのかもしれません。

      問題が解決することを祈ってます。
      • 試しにFCKeditorプラグインを新規にインストールしてみようとしたところ、インストールできませんでした。
        原因は調査中ですが、インストーラ同梱のsqlParser.class.phpやらが0962ベース以上では問題ある気がします。
        よく調べてみます。
        • FCKeditorプラグインのインストーラを暫定的に改修したうえで試してみたところ、画像のアップロードができました。

          MODx本体をアップデートした場合に、もともと稼働していたFCKeditorの挙動がおかしくなるという問題と、
          MODx0963を新規にインストールした状態でさらにFCKeditorを新規インストールできないという
          2つの問題があるみたいですね。
          • laughありがとうございました。この投稿を見た後アップグレード前の画面と見比べてみたところたしかにベースパスが補完されていないようでした。おかげでちゃんと表示されるようになりました。

            じつは投稿後、現実からの逃避で今まで眠りについておりました。

            ありがとうございました。

            Quote from: sama55 at Dec 25, 2008, 01:26 PM

            もう解決されたかもしれませんが、私も同じ状態になり対処しました。
            ベースパスが補完されなくなったことが原因のようです。
            同じ原因でない可能性もありますが、まずは以下のことをご確認ください。
            • rolleyesいつもROM専用だったのでここに投稿するのまでにだいぶ勇気が必要でした。
              アップグレードが発表されてから何時間もたってるし、開発関係の方のご自身のホームページもアップグレード確認しているはずなのでこの問題は自分自身の問題かと悩んでおりました。

              今後ともよろしくお願いいたします。

              Quote from: yama at Dec 25, 2008, 02:48 PM

              FCKeditorプラグインのインストーラを暫定的に改修したうえで試してみたところ、画像のアップロードができました。

              MODx本体をアップデートした場合に、もともと稼働していたFCKeditorの挙動がおかしくなるという問題と、
              MODx0963を新規にインストールした状態でさらにFCKeditorを新規インストールできないという
              2つの問題があるみたいですね。