We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 10270
    • 5 Posts
    はじめまして。MODxをインストールできなくて困ってます。
    SQL文のエラーでtableが作成できないと言われてると思うのですが、
    他のサーバにはエラーなく無事にインストールできました。
    お分かりの方見えましたらご教授して頂けませんか?

    Apache/1.3.37
    PHP Version 4.3.11
    mysql4.1.12
    modx0.96

    エラー内容
    -------------------------------------------------------------------------------------------
    Install results

    Setup will now attempt to setup the database:

    Creating connection to the database: OK!

    Selecting database `vmw7_agg`: OK!

    Checking table prefix `gifu_`: OK!

    Creating database tables: Database Alerts!

    MODx setup couldn’t install/alter some tables inside the selected database.

    The following errors had occurred during installation

    Column ’pagetitle’ cannot be part of FULLTEXT index during the execution of SQL statement CREATE TABLE IF NOT EXISTS `gifu_site_content` ( `id` int(10) NOT NULL auto_increment, `type` varchar(20) NOT NULL default ’document’, `contentType` varchar(50) NOT NULL default ’text/html’, `pagetitle` varchar(255) NOT NULL default ’’, `longtitle` varchar(255) NOT NULL default ’’, `description` varchar(255) NOT NULL default ’’, `alias` varchar(255) default ’’, `link_attributes` varchar(255) NOT NULL default ’’, `published` int(1) NOT NULL default ’0’, `pub_date` int(20) NOT NULL default ’0’, `unpub_date` int(20) NOT NULL default ’0’, `parent` int(10) NOT NULL default ’0’, `isfolder` int(1) NOT NULL default ’0’, `introtext` text COMMENT ’Used to provide quick summary of the document’, `content` mediumtext, `richtext` tinyint(1) NOT NULL default ’1’, `template` int(10) NOT NULL default ’1’, `menuindex` int(10) NOT NULL default ’0’, `searchable` int(1) NOT NULL default ’1’, `cacheable` int(1) NOT NULL default ’1’, `createdby` int(10) NOT NULL default ’0’, `createdon` int(20) NOT NULL default ’0’, `editedby` int(10) NOT NULL default ’0’, `editedon` int(20) NOT NULL default ’0’, `deleted` int(1) NOT NULL default ’0’, `deletedon` int(20) NOT NULL default ’0’, `deletedby` int(10) NOT NULL default ’0’, `publishedon` int(20) NOT NULL default ’0’, `publishedby` int(10) NOT NULL default ’0’, `menutitle` varchar(255) NOT NULL DEFAULT ’’ COMMENT ’Menu title’, `donthit` tinyint(1) NOT NULL default ’0’ COMMENT ’Disable page hit count’, `haskeywords` tinyint(1) NOT NULL default ’0’ COMMENT ’has links to keywords’, `hasmetatags` tinyint(1) NOT NULL default ’0’ COMMENT ’has links to meta tags’, `privateweb` tinyint(1) NOT NULL default ’0’ COMMENT ’Private web document’, `privatemgr` tinyint(1) NOT NULL default ’0’ COMMENT ’Private manager document’, `content_dispo` tinyint(1) NOT NULL default ’0’ COMMENT ’0-inline, 1-attachment’, `hidemenu` tinyint(1) NOT NULL DEFAULT ’0’ COMMENT ’Hide document from menu’, PRIMARY KEY (`id`), KEY `id` (`id`), KEY `parent` (`parent`), KEY aliasidx (alias), FULLTEXT KEY `content_ft_idx` (`pagetitle`,`description`,`content`) ) TYPE=MyISAM COMMENT=’Contains the site document tree.’.


    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement ALTER TABLE `gifu_site_content` ADD INDEX `aliasidx` (alias).
    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement ALTER TABLE `gifu_site_content` ADD COLUMN `introtext` text COMMENT ’Used to provide quick summary of the document’ AFTER `isfolder`.
    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement ALTER TABLE `gifu_site_content` ADD COLUMN `menutitle` varchar(255) NOT NULL default ’’ COMMENT ’Menu title’ AFTER `deletedby`, ADD COLUMN `donthit` tinyint(1) NOT NULL default ’0’ COMMENT ’Disable page hit count’ AFTER `menutitle`, ADD COLUMN `haskeywords` tinyint(1) NOT NULL default ’0’ COMMENT ’has links to keywords’ AFTER `donthit`, ADD COLUMN `hasmetatags` tinyint(1) NOT NULL default ’0’ COMMENT ’has links to meta tags’ AFTER `haskeywords`, ADD COLUMN `privateweb` tinyint(1) NOT NULL default ’0’ COMMENT ’Private web document’ AFTER `hasmetatags`, ADD COLUMN `privatemgr` tinyint(1) NOT NULL default ’0’ COMMENT ’Private manager document’ AFTER `privateweb`.
    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement ALTER TABLE `gifu_site_content` ADD COLUMN `content_dispo` tinyint(1) NOT NULL DEFAULT ’0’ COMMENT ’0-inline, 1-attachment’ AFTER `privatemgr`.
    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement ALTER TABLE `gifu_site_content` ADD COLUMN `hidemenu` tinyint(1) NOT NULL DEFAULT ’0’ COMMENT ’Hide document from menu’ AFTER `content_dispo`.
    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement ALTER TABLE `gifu_site_content` ADD COLUMN `publishedon` int(20) NOT NULL DEFAULT ’0’ COMMENT ’Date the document was published’ AFTER `deletedby`.
    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement ALTER TABLE `gifu_site_content` ADD COLUMN `publishedby` int(10) NOT NULL DEFAULT ’0’ COMMENT ’ID of user who published the document’ AFTER `publishedon`.
    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement ALTER TABLE `gifu_site_content` MODIFY COLUMN `pagetitle` varchar(255) NOT NULL default ’’, MODIFY COLUMN `alias` varchar(255) default ’’, MODIFY COLUMN `menutitle` varchar(255) NOT NULL DEFAULT ’’ COMMENT ’Menu title’.
    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement ALTER TABLE `gifu_site_content` ADD COLUMN `link_attributes` varchar(255) NOT NULL DEFAULT ’’ COMMENT ’Link attriubtes’ AFTER `alias`.
    --------------------------------------------------------------------------------
    Table ’vmw7_agg.gifu_site_content’ doesn’t exist during the execution of SQL statement REPLACE INTO `gifu_site_content` VALUES (1,’document’,’text/html’,’MODx CMS Install Success’,’Welcome to the MODx Content Management System’,’’,’minimal-base’,’’,1,0,0,0,0,’’,’Install Successful!\r\nYou have successfully installed and configured MODx. We hope you find this site an adequate starting configuration for many small business, organization or personal websites; just change out the template and add your own content and snippets, and you\’ll be good to go! \r\n\r\nGetting Help\r\nThe team behind MODx strives to contantly add to and refine the documentation to help you get up to speed with MODx:\r\n\r\n For basic instructions on integrating custom templates into MODx, please see the Designer\’s Guide. \r\n For an introduction to working in MODx from the content editors perspectve, see the Content Editor\’s Guide. \r\n For a detailed overview of the backend "manager" and setting up Users and Groups, please peruse the Administration Guide.\r\n For developers, architecture and API documentation can be found in the Developer\’s Guide.\r\n And if someone has installed this site for you, but you\’re curious as to the steps they went through, please see the Getting Started Guide.\r\n\r\n\r\nAnd don\’t forget, you can always learn and ask questions at the MODx forums. \r\n’,1,3,0,1,1,1,1130304721,1,1130304927,0,0,0,1130304721,1,’Base Install’,0,0,0,0,0,0,0).
    -----------------------------------------------------------------------------------

    同じ様なトピックスもあったのですが、
    エラー内容が違うため解決できませんでした。

    すいませんが、教えていただけますか?
      • 21772
      • 69 Posts
      こんにちは

      アドバイスにもなっていませんが...
      エラー内容と、MODxバージョン、mysqlのバージョンなども違うとおもうのですが、
      次のトピックなどが参考になりませんか?
      http://modxcms.com/forums/index.php?topic=3537.0

      参考にするのはphpMyAdminなどでの作業の部分ですが、MODxのinstallフォルダ
      の中のsetup.sqlのsql文をphpMyAdminで実行してみて、より詳しい状況を確認してみるとか..

      自分はphpMyAdminもあまり使った事がないので、あてずっぽうですが、
      より詳しいエラーとか見えるんじゃないでしょうか?
        • 10270
        • 5 Posts
        早速のお返事ありがとうございます。
        http://modxcms.com/forums/index.php?topic=3537.0
        のトピックスも参考にさせて頂きましたが、同じようにエラー内容のtableだけ
        作成できていませんでした。
        InnoDBテーブルが原因かと思ったのですが、phpMyAdminのストレージエンジンのステータスを
        見ると対応しているようですし、
        >install/setup.sql内の「InnoDB」を全て「MyISAM」に置換します。
        >そして、install/index.phpを実行します。
        こちらもすべてはじめからMyISAMになっていました。
        これはもうサーバを変えないとだめなのでしょうか?

        宜しくお願いします。
          • 10270
          • 5 Posts
          すいません。
          直接エラーの出てるSQL構文をPhpMyAdminで試したら、
          次のようなエラーが出ました。

          Column ’pagetitle’ cannot be part of FULLTEXT index

          ちゃんとtableが作成できたものはSQL構文を入れると
          エラーなく作成されました。

          これは原因なのでしょうか??

          お願いします。
            • 36592
            • 970 Posts
            MySQLは全然分からない人(=私)がしゃしゃり出ることでもないんですが...笑

            Quote from: fujiwara at Oct 12, 2007, 12:15 AM

            Column ’pagetitle’ cannot be part of FULLTEXT index
            このエラーは最初のfujiwaraさんの投稿にもちゃんと出てますね~

            こんなのを見つけました。
            http://japan.nucleuscms.org/bb/viewtopic.php?p=9322&
            Nucleusの話ですが、どうやらMySQLのデータベースの文字コードが関係しているみたいです。

            あとこんなのも。
            http://xoopscube.jp/modules/xhnewbb/viewtopic.php?topic_id=1220
            4.1系から搭載された文字コードの自動変換機能がどうのこうの... なんて話になっていますね。

            レンタルサーバー等でMySQLの設定を変えることができないと、そのサーバーでの運用は面倒になるかもしれませんね。
            MODxインストール時やインストール後のMySQLへのアクセスに「set character set utf8;」なんてSQLを自分で埋め込まないといけなくなりそう。

            あとは専門家の方にコメントを頂きたく...笑
              • 10270
              • 5 Posts
              ありがとうございます。
              参考にさせて頂きます。

              とりあえず、今回早急に納期に間に合わせるため、
              別のサーバで契約しようと思います。

              有り難うございました!!
                • 4017
                • 2 Posts
                大分前の投稿でもう終わっているトピックかと思いましたが、全く同じ症状がでましたが、
                文字セットを変えるだけで正常にインストールできたため投稿させていただきます。

                データベース作成時にphpMyadminのSQLのページで
                alter database ”modxで利用するデータベース名” defalt character set utf8;
                とコマンドを実行

                以降通常の流れの通りインストール。
                文字セットに起因して起こる現象のようです。