We launched new forums in March 2019—join us there. In a hurry for help with your website? Get Help Now!
    • 33300
    • 18 Posts
    Hi Ger-Community wink

    Ich habe ein Problem mit den friendly-urls... Mein host ist http://www.one.com.

    Hier die htaccess datei:
    # -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>

    Weiss jemand wie ich das modifizieren muss, oder ob es überhaupt geht?
    Oder kennt jemand einen besseren deutschen host? GIbt es evntl. schon modx angepasste server?

    Dank und Gruß
    z00la
      • 29181
      • 480 Posts
      Hi,
      ich habe vor lange Zeit auch bei One.com nachgefragt ob die mod_rewrite unterstützen und sie haben Nein gesagt.

      Bist du dir sicher das dein webspace mod_rewrite hat?

      Hoffentlich kannst du mein Deutsch verstehen.

      Taff
        Adrian Lawley: www.adrianlawley.com
        • 33300
        • 18 Posts
        Hi Taff und danke für deine Antwort!

        Ich bin mir ÜBERHAUPT nicht sicher ob die das unterstützen, kenne mich gar nicht aus leider sad

        Hoffe ich muss nicht umziehn, weil ich erst vor kurzem zu one gestoßen bin...

        grüße z00la
          • 29181
          • 480 Posts
          Bei one.com ist der Live help das beste was man haben kann...Ich hoffe du findest bald einen Antwort.

          Grüß
          Taff
            Adrian Lawley: www.adrianlawley.com
            • 36451
            • 264 Posts
            Du hast MODx doch schon installiert? Sieh jetzt einfach im Manager nach, ob mod_rewrite zur Verfügung steht: Berichte -> Systeminfo -> phpinfo() -> Ansehen

            Im Abschnitt "apache2handler" muß in der Zeile "Loaded Modules" etwas von "mod_rewrite" stehen. Falls das der Fall ist -> prima. Jetzt nimmst Du Dir die Anleitung aus dem Wiki und richtest die friendly urls ein.

            Falls Du MODx noch nicht installiert hast, erstellst Du Dir eine PHP Datei namens info.php, darin steht nichts weiter als
            <?php phpinfo(); ?>
            Diese Datei lädst Du per FTP auf Deinen Server. Dann rufst Du sie in Deinem Browser auf: http://www.deinedomain.de/info.php Hier findest Du wie im 2. Absatz beschrieben heraus, ob das Modul mod_rewrite bei One installiert ist.
              • 33300
              • 18 Posts
              wow dank wiki hat es einigermaßen hingehauen!
              die friendly urls gehen, die seiten werden nun angezeigt.

              ein fehler ist aber nun beim quickedit aufgetreten, was das ausehen der kompleten Seite zerstört.
              Die schöne graue QuickEdit bar ist nämlich verschwunden und das ganze ist jetzt links oben als ganz normales text menü (sieht aus als hätte ich die css entfernt).
              Auf der startseite nicht (www.adresse.de/modx/) , aber auf allen anderen (www.adresse.de/modx/seite2.html).

              woran könnte das liegen? in der phpinfo finde ich keinen mod_rewrite eintrag, aber funktionieren tut es huh
                • 29181
                • 480 Posts
                Zoola,
                dieses Problem ist bei mir auch schon vorgekommen.

                Ich glaube es liegt daran das du irgendwo ein Tag nicht richtig geschlossen hast oder sowas. Ich habe damals die Template die nicht richtig funktionierte stück für stück gelöscht bis ich den Fehler hatte....(Speichere es vorher ab grin )

                Viel Glück,
                Taff
                  Adrian Lawley: www.adrianlawley.com
                  • 33300
                  • 18 Posts
                  hm komisch, da mir der markup validation service nur einen fehler in der datei ausgibt und das is der quickedit tag (was ja normal is).
                  ansonsten keine fehler (is sogar strict).

                  das komische is auch das der fehler gar nicht kommt wenn ichs ohne friendly urls mache, aber mal schauen, ich werd mir den code mal genauer anschauen!

                  vielen dank für die hilfe!

                  z00la