On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Bonjour à tous,

    Je viens juste de m’inscrire sur ce forum. Tout d’abord Bravo à MODx que je découvre avec fascination depuis quelques semaines..

    Je rencontre un problème incompréhensible depuis qqes jours concernant l’utilisation de css comme document MODx .

    Après avoir essayé des tas et des tas de trucs piochés par ci par là sur les forums je poste ici en désespoir de cause, mon niveau d’anglais n’étant pas suffisant pour poster côté anglophone...

    Je m’explique.

    J’ai fait un install en local sous Windows (Vista certes mais qd meme) sur un WAMPServer 2.0 qui tourne bien. Ma version de MODx est la 0.9.6.2. bien installé dans un repertoire modx à la racine de de wamp soit wamp/www/modx. (histoire que tout soit clair).

    Donc je fais bien ce qui est expliqué dans le tuto.

    1/ créer un document-répertoire que j’appelle "css"
    2 / créer dans ce répertoire un document "stylesBasiques.css"
    3/ je mets dans mon modèle <style="text/css>@import url(’css/stylesBasiques.css’)

    J’effectue les modifs du htaccess et hop je teste ... Et là... RIEN ... zéro mise en page ! juste mes pages html qui s’affichent sans aucun style ! sad


    Pour prévenir les questions de base :

    les URL simplifiées sont actives dans MODx
    "utiliser les alias simples" et "chemin d’acces pour les alias simples" sont sur oui
    mon document stylesBasiques.css pour "type de contenu" : text/css


    J’ai tenté de taper directement l’adresse localhost/modx/css/stylesBasiques.css j’obtiens une erreur 404
    idem si j’essaie d’acceder a localhost/modx/css j’obtiens une erreur 404

    En revanche si je fais : localhost/modx/index.php?id=8 (ou 8 est l’id de mon document stylesBasiques.css) j’ai bien ma page css qui s’affiche.

    J’y comprends plus rien... J’ai aussi essayé une réinstall complète et toujours pareil !!!! Je tourne bourrique !!!

    Y a t il qqn qui a déjà rencontré ce problème ? J’aimerais trouver une solution et comprendre le pourquoi du comment de ce *!#&+!! de truc !

    Merci d’avance.
    anso