On March 26, 2019 we launched new MODX Forums. Please join us at the new MODX Community Forums.
Subscribe: RSS
  • Hello à vous !

    Petite question, j’essaie d’appeler une image dans un document via un chunk, problème c’est que cela ne fonctionne pas...mais est-ce seulement possible de faire cela ?

    Voici le code de mon chunk: (voir tvimage_100-100)
    <div class="module-text">
    				<table class="module-text-toolbar">
    					<tr>
    						<td><h1>[*artiste_nc*]</h1></td>
    						<td class="commands"> </td>
    					</tr>
    					<tr>
    					  <td><h1>[*longtitle*]</h1></td>
    					  <td class="commands"> </td>
    				  </tr>
    				</table>
    				<p class="author">Ecrit par [*auteur_n1*]</p>
    				<p class="created">Le [[AuthorTime? &dateFormat=`%d %B %Y` &usedDate=`createdon` &tpl=`[+Date+]`]]</p>
    				<div class="image-caption-left">
    					<img src="[+tvimage_100-100+]" width="100" height="100" alt="[*artiste_nc*]" class="teaser-pic" /> 
    					<!--<p>commentaire photo</p>-->
    				</div>
    				<p>[*content*]</p>
    				<p align="center" class="updated"> </p>
    				<p align="center" class="updated">[*youtubelink*]</p>
    </div>
    


    Est-ce que quelqu’un voit ce que je fais faux dans mon appel ?

    Merci d’avance.

    Mehdi
      Scuse my english...I&#39;m swiss
    • anonymized-26931 Reply #2, 11 years ago
      salut mehdi,

      essay appeler les TVs comme ca dans tes Chunks:
      [+artiste_nc+]


      jan
      • Jean-Christophe B. Reply #3, 11 years ago
        Bonjour,
        Quote from: mehdi at Oct 17, 2009, 03:00 PM

        Petite question, j’essaie d’appeler une image dans un document via un chunk, problème c’est que cela ne fonctionne pas...mais est-ce seulement possible de faire cela ?
        Peux-tu poster le code source généré par le navigateur ?

        Quote from: mehdi at Oct 17, 2009, 03:00 PM

        Voici le code de mon chunk: (voir tvimage_100-100)
        <div class="module-text">
        				<table class="module-text-toolbar">
        					<tr>
        						<td><h1>[*artiste_nc*]</h1></td>
        						<td class="commands"> </td>
        					</tr>
        					<tr>
        					  <td><h1>[*longtitle*]</h1></td>
        					  <td class="commands"> </td>
        				  </tr>
        				</table>
        				<p class="author">Ecrit par [*auteur_n1*]</p>
        				<p class="created">Le [[AuthorTime? &dateFormat=`%d %B %Y` &usedDate=`createdon` &tpl=`[+Date+]`]]</p>
        				<div class="image-caption-left">
        					<img src="[+tvimage_100-100+]" width="100" height="100" alt="[*artiste_nc*]" class="teaser-pic" /> 
        					<!--<p>commentaire photo</p>-->
        				</div>
        				<p>[*content*]</p>
        				<p align="center" class="updated"> </p>
        				<p align="center" class="updated">[*youtubelink*]</p>
        </div>
        


        Est-ce que quelqu’un voit ce que je fais faux dans mon appel ?
        Si tu n’as spécifié aucun widget, c’est correct et ça devrait fonctionner.
        Par contre, si tu as précisé un widget de type Image, pas besoin d’inclure la balise <img>. Le code est généré automatiquement.

        Au passage, tes autres TVs devraient également être sous la forme: [+nomdemaTV+] et non pas [*nomdematv*].
          Intégrateur web freelance
        • Hello,

          Avec du retard (le mail était passé dans le spam), je vous remercie pour votre aide et je vais essayer tout ça !
            Scuse my english...I&#39;m swiss